summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:08:02 +0100
committermschubert2015-06-12 12:08:02 +0100
commit3f1f4e05b064229981e119bee5ac81ac56ec0147 (patch)
tree7d22b42a5aba9e0b5f13bb636e4a17bb3ba48570
downloadaur-3f1f4e05b064229981e119bee5ac81ac56ec0147.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4aea3dcd4110
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pydstool
+ pkgdesc = Simulation and analysis environment for dynamical systems
+ pkgver = 0.88.111221
+ pkgrel = 1
+ url = http://www2.gsu.edu/~matrhc/ProjectOverview.html
+ arch = any
+ license = BSD
+ makedepends = dos2unix
+ depends = python2-numpy
+ depends = python2-scipy
+ optdepends = python2-sloppycell
+ replaces = pydstool
+ options = !emptydirs
+ source = http://sourceforge.net/projects/pydstool/files/pydstool/0.88/PyDSTool-0.88.111221.zip
+ md5sums = a58422c0b5755f31340f5707874a4629
+
+pkgname = python2-pydstool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..629070b58a3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=python2-pydstool
+_pkgname=pydstool
+_pkgName=PyDSTool
+pkgver=0.88.111221
+_pkgver=0.88
+pkgrel=1
+pkgdesc="Simulation and analysis environment for dynamical systems"
+url="http://www2.gsu.edu/~matrhc/ProjectOverview.html"
+license=('BSD')
+arch=('any')
+depends=('python2-numpy' 'python2-scipy')
+makedepends=('dos2unix')
+optdepends=('python2-sloppycell')
+replaces=('pydstool')
+source=("http://sourceforge.net/projects/$_pkgname/files/$_pkgname/$_pkgver/$_pkgName-$pkgver.zip")
+options=('!emptydirs')
+md5sums=('a58422c0b5755f31340f5707874a4629')
+
+build() {
+ cd "$srcdir/$_pkgName"
+ make unixify
+}
+
+package() {
+ pydir=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
+ mkdir -p "$pkgdir/$pydir" && cd "$pkgdir/$pydir"
+ cp -dr --no-preserve=ownership "$srcdir/$_pkgName" .
+ sed -i "/assert(callable, func)/d" PyDSTool/common.py
+ echo $_pkgName > "PyDSTool.pth"
+
+ find . -type f -exec chmod 644 {} \;
+ find . -type d -exec chmod 755 {} \;
+ find . -name "*.py" -exec sed -i '1s/python2.3$/python2/' {} \;
+ find . -name "__init__.py" -exec chmod a+x {} \;
+
+ python2 -c "import PyDSTool"
+}