summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:19:05 +0200
committerM0Rf302015-06-17 16:19:05 +0200
commit89adbec81d36dae973fd48a88a3d029530a6b920 (patch)
tree6be5810de371f7d531c58d7601bb357c91f35771
downloadaur-89adbec81d36dae973fd48a88a3d029530a6b920.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
3 files changed, 55 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..bca8f5b38911
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pyelliptic-git
+ pkgdesc = Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish...
+ pkgver = 69.7810c7a
+ pkgrel = 1
+ url = https://github.com/yann2192/pyelliptic
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = openssl
+ conflicts = python2-pyelliptic
+ source = pyelliptic::git+https://github.com/yann2192/pyelliptic.git
+
+pkgname = python2-pyelliptic-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c48d3011ac48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pyelliptic-git
+ pkgdesc = Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish...
+ pkgver = 69.7810c7a
+ pkgrel = 1
+ url = https://github.com/yann2192/pyelliptic
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = openssl
+ conflicts = python2-pyelliptic
+ source = pyelliptic::git+https://github.com/yann2192/pyelliptic.git
+ md5sums = SKIP
+
+pkgname = python2-pyelliptic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab3ea972a0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+
+_pkgname=python2-pyelliptic
+pkgname=$_pkgname-git
+pkgver=69.7810c7a
+pkgrel=1
+pkgdesc="Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish..."
+arch=(any)
+url="https://github.com/yann2192/pyelliptic"
+license=('GPL3')
+depends=('openssl')
+makedepends=('git')
+source=('pyelliptic::git+https://github.com/yann2192/pyelliptic.git')
+conflicts=('python2-pyelliptic')
+
+package(){
+ cd pyelliptic
+ python2 setup.py install --root="$pkgdir"
+}
+
+pkgver() {
+ cd pyelliptic
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')