summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitbf108ce45453ae86b87e2d9c17709f4b7abc5e7e (patch)
treea8239ddc55b3fc9a044af4d049d98eb2207a66a2
downloadaur-bf108ce45453ae86b87e2d9c17709f4b7abc5e7e.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c45a5942595
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-pyethash
+ pkgdesc = Python wrappers for ethash, the Ethereum proof of work hashing function
+ pkgver = 23.1
+ pkgrel = 1
+ url = https://github.com/ethereum/ethash
+ arch = i686
+ arch = x86_64
+ groups = ethereum
+ license = GPL
+ makedepends = gcc
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/pyethash/pyethash-23.1.tar.gz
+ md5sums = bdb22f4a88fb0c0e8f5da5fad0c840cc
+ sha256sums = 1e001fe8b75b5c86e60a0685b3e6a0f1b02df494629240c720ffdcf991e518be
+
+pkgname = python2-pyethash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4808d417f6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-pyethash
+pkgver=23.1
+pkgrel=1
+pkgdesc="Python wrappers for ethash, the Ethereum proof of work hashing function"
+arch=('i686' 'x86_64')
+depends=('python2')
+makedepends=('gcc' 'python2-setuptools')
+groups=('ethereum')
+url="https://github.com/ethereum/ethash"
+license=('GPL')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/p/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('bdb22f4a88fb0c0e8f5da5fad0c840cc')
+sha256sums=('1e001fe8b75b5c86e60a0685b3e6a0f1b02df494629240c720ffdcf991e518be')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}