summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:25 +0200
committerSébastien Leduc2015-06-13 10:51:25 +0200
commitf90bf3ef513bcdbbd45b6a8344497de86dc43e5b (patch)
tree16404759c17a120517b113e82c886a16e34618ba
downloadaur-f90bf3ef513bcdbbd45b6a8344497de86dc43e5b.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
3 files changed, 58 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a1abf487aadd
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pyftpdlib
+ pkgdesc = Complete asynchronous FTP server library in Python
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://pyftpdlib.googlecode.com
+ arch = any
+ license = MIT
+ depends = python2
+ optdepends = python2-sendfile: used to speedup transfers
+ optdepends = python2-pyopenssl: used for SSL support
+ conflicts = pyftpdlib
+ source = https://pypi.python.org/packages/source/p/pyftpdlib/pyftpdlib-1.4.0.tar.gz
+
+pkgname = python2-pyftpdlib
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09ce056dd57f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-pyftpdlib
+ pkgdesc = Complete asynchronous FTP server library in Python
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://pyftpdlib.googlecode.com
+ arch = any
+ license = MIT
+ depends = python2
+ optdepends = python2-sendfile: used to speedup transfers
+ optdepends = python2-pyopenssl: used for SSL support
+ conflicts = pyftpdlib
+ source = https://pypi.python.org/packages/source/p/pyftpdlib/pyftpdlib-1.4.0.tar.gz
+ md5sums = 5aeda8287f4e5ba263e48a79f2a246fd
+
+pkgname = python2-pyftpdlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b9d5fca0f9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+# Contributor: Stephane Travostino <stephane.travostino@gmail.com>
+
+pkgname=python2-pyftpdlib
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Complete asynchronous FTP server library in Python"
+arch=('any')
+url='http://pyftpdlib.googlecode.com'
+license=('MIT')
+depends=('python2')
+optdepends=("python2-sendfile: used to speedup transfers"
+ "python2-pyopenssl: used for SSL support")
+conflicts=('pyftpdlib')
+source=("https://pypi.python.org/packages/source/p/pyftpdlib/pyftpdlib-${pkgver}.tar.gz")
+md5sums=('5aeda8287f4e5ba263e48a79f2a246fd')
+
+build() {
+ cd "$srcdir/pyftpdlib-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/pyftpdlib-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+# vim:set ts=2 sw=2 et: