summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-08-18 15:56:48 -0400
committerTed Alff2022-08-18 15:56:48 -0400
commit048f5531ae3b0ab78a5f0154fffb6ff4cdff607b (patch)
treee65cbe03e363be8e0ec2538c4e38c6af278eee3b
parentb4d3bc6624705eb2d8b201c0bc2af2edfcaad8c4 (diff)
downloadaur-python2-pygame.tar.gz
Update dependencies to sdl2_*
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9e8578c3e68..d78936b9b997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python2-pygame
pkgdesc = Python game library
pkgver = 2.0.3
- pkgrel = 1
- url = http://www.pygame.org/
+ pkgrel = 2
+ url = https://www.pygame.org/
arch = x86_64
arch = i686
arch = armv7h
arch = aarch64
license = LGPL
makedepends = python2-setuptools
- depends = sdl_mixer
- depends = sdl_ttf
- depends = sdl_image
+ makedepends = sdl2
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ depends = sdl2_image
depends = python2
depends = portmidi
source = https://pypi.io/packages/source/p/pygame/pygame-2.0.3.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4b50fbc6ff0b..df30ff002448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=python2-pygame
pkgver=2.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python game library"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
-url="http://www.pygame.org/"
+url="https://www.pygame.org/"
license=('LGPL')
-depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'python2' 'portmidi')
-makedepends=('python2-setuptools')
+depends=('sdl2_mixer' 'sdl2_ttf' 'sdl2_image' 'python2' 'portmidi')
+makedepends=('python2-setuptools' 'sdl2')
source=("https://pypi.io/packages/source/p/pygame/pygame-$pkgver.tar.gz")
sha256sums=('d097f2802a9d0d7fb40c49c789af2984b202baa8fd32701082598755f5973f51')
prepare() {
cd pygame-${pkgver}
- # don't ship python2 *and* python3 compiled bytecode from upstream
+ # don't ship compiled bytecode from upstream
find . -name "*.pyc" -delete
find . -type f -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} +
}
@@ -29,7 +29,7 @@ package_python2-pygame() {
python2 setup.py install --root="${pkgdir}" --prefix=/usr
# Copying the examples
- cp -R examples "${pkgdir}/usr/lib/python2.7/site-packages/pygame"
+ cp -R examples "${pkgdir}"/usr/lib/python2.7/site-packages/pygame
# Fixing permissions
chmod 644 "${pkgdir}"/usr/include/python2.7/pygame/*