summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-12-11 07:51:03 -0500
committeréclairevoyant2022-12-11 08:01:09 -0500
commitca67b06e454586fbaa964364c1c5a0407e0a4ea2 (patch)
tree82660ee0630201578cfed1090e935c6cece83923
parentab407d52b9c5d50b25ff6489118208a4ec41d614 (diff)
downloadaur-ca67b06e454586fbaa964364c1c5a0407e0a4ea2.tar.gz
python2-pygame-sdl2-git: fix license, makedeps
remove extra source file Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
-rw-r--r--cython.patch11
3 files changed, 27 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f5138869d9e..2a89537de319 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python2-pygame-sdl2-git
- pkgdesc = A new, SDL2-based implementation of the Pygame API (dev channel)
- pkgver = 412.bed8099
+ pkgdesc = SDL2-based implementation of the Pygame API
+ pkgver = 413.c99de26
pkgrel = 1
url = https://github.com/renpy/pygame_sdl2
arch = i686
arch = x86_64
arch = aarch64
license = LGPL2.1
- license = zlib
- makedepends = git
+ license = custom:zlib
makedepends = cython2
+ makedepends = git
+ makedepends = python2-setuptools
depends = sdl2
depends = sdl2_gfx
depends = sdl2_image
@@ -18,8 +19,6 @@ pkgbase = python2-pygame-sdl2-git
provides = python2-pygame-sdl2
conflicts = python2-pygame-sdl2
source = git+https://github.com/renpy/pygame_sdl2.git
- source = cython.patch
- md5sums = SKIP
- md5sums = 142fa70196ab3308826ca24d3527065d
+ b2sums = SKIP
pkgname = python2-pygame-sdl2-git
diff --git a/PKGBUILD b/PKGBUILD
index d160d14d3f15..a8af4d2cc3c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
-# Maintainer: Cravix < dr dot neemous at gmail dot com >
+# Maintainer: éclairevoyant
+# Contributor: Cravix < dr dot neemous at gmail dot com >
pkgname=python2-pygame-sdl2-git
-_pkgname=pygame_sdl2
-pkgver=412.bed8099
+_gitname=pygame_sdl2
+pkgver=413.c99de26
pkgrel=1
-pkgdesc="A new, SDL2-based implementation of the Pygame API (dev channel)"
+pkgdesc="SDL2-based implementation of the Pygame API"
arch=('i686' 'x86_64' 'aarch64')
-url="https://github.com/renpy/$_pkgname"
-license=('LGPL2.1' 'zlib')
+url="https://github.com/renpy/$_gitname"
+license=('LGPL2.1' 'custom:zlib')
depends=('sdl2' 'sdl2_gfx' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
-makedepends=('git' 'cython2')
+makedepends=('cython2' 'git' 'python2-setuptools')
provides=('python2-pygame-sdl2')
conflicts=('python2-pygame-sdl2')
-source=("git+https://github.com/renpy/$_pkgname.git"
- 'cython.patch')
-md5sums=('SKIP'
- '142fa70196ab3308826ca24d3527065d')
+source=("git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+prepare() {
+ sed -i '/cython_command = "cython"/ s/n"/n2"/' $_gitname/setuplib.py
}
build() {
- cd "$srcdir/$_pkgname"
-
- patch -Np0 -i ../cython.patch
- python2 setup.py build
+ cd $_gitname
+ python2 setup.py build
}
package() {
- cd "$srcdir/$_pkgname"
- python2 setup.py install --root="$pkgdir" || return 1
+ cd $_gitname
+ python2 setup.py install --root="$pkgdir"
+ install -Dm644 COPYING.ZLIB "$pkgdir/usr/share/licenses/$pkgname/LICENSE.zlib"
+ ln -s '../common/LGPL2.1' "$pkgdir/usr/share/licenses/$pkgname/LICENSE.LGPL2_1"
}
diff --git a/cython.patch b/cython.patch
deleted file mode 100644
index 0bcc646c7e69..000000000000
--- a/cython.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setuplib.py 2016-03-30 10:36:25.300030343 +0800
-+++ setuplib.py.cur 2016-03-30 10:39:04.186704987 +0800
-@@ -58,7 +58,7 @@
- if windows:
- cython_command = os.path.join(os.path.dirname(sys.executable), "Scripts", "cython.exe")
- else:
-- cython_command = "cython"
-+ cython_command = "cython2"
-
-
- if sys.version_info[0] >= 3: