summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2017-05-22 15:58:28 +0200
committergraziano.giuliani2017-05-22 15:58:28 +0200
commit4d63f1bbd76211b2b9a91e5da9661b2560c376d1 (patch)
treea20bbe1eae860613403485ab995ca26171d1f76f
parent8e6736ccaf09f4bdedc26be746ac0779ed888831 (diff)
downloadaur-4d63f1bbd76211b2b9a91e5da9661b2560c376d1.tar.gz
Use git base
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abfe65bba5f9..a5909c0a8a5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 22 12:59:03 UTC 2016
+# Mon May 22 13:58:17 UTC 2017
pkgbase = python2-pygrib
pkgdesc = Python module for reading and writing GRIB (editions 1 and 2) files.
pkgver = 2.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jswhit/pygrib
arch = i686
arch = x86_64
@@ -12,9 +12,9 @@ pkgbase = python2-pygrib
depends = jasper
depends = python2-numpy
depends = eccodes
- source = https://pypi.python.org/packages/source/p/pygrib/pygrib-2.0.1.tar.gz
+ source = git://github.com/jswhit/pygrib
source = setup.cfg
- md5sums = e9ae04cb987992691b388b16be53214a
+ md5sums = SKIP
md5sums = d5a6f196213d2a53c280c7be1cb1bb03
pkgname = python2-pygrib
diff --git a/PKGBUILD b/PKGBUILD
index a6f1702b6cf5..2ea1fa0bcec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Maintainer : Graziano Giuliani <graziano.giuliani@gmail.com>
pkgname=python2-pygrib
+_gitname=pygrib
pkgver=2.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Python module for reading and writing GRIB (editions 1 and 2) files."
arch=('i686' 'x86_64')
url="https://github.com/jswhit/pygrib"
license=('MIT')
depends=('python2-pyproj' 'jasper' 'python2-numpy' 'eccodes')
-source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz setup.cfg)
-md5sums=('e9ae04cb987992691b388b16be53214a'
+source=(git://github.com/jswhit/$_gitname setup.cfg)
+md5sums=('SKIP'
'd5a6f196213d2a53c280c7be1cb1bb03')
build() {
- cd "${srcdir}/pygrib-${pkgver}"
+ cd "${srcdir}/$_gitname"
export JASPER_DIR=/usr
export PNG_DIR=/usr
export ZLIB_DIR=/usr
@@ -25,7 +26,7 @@ build() {
}
package() {
- cd "${srcdir}/pygrib-${pkgver}"
+ cd "${srcdir}/$_gitname"
python2 setup.py install --prefix=/usr \
--root="${pkgdir}" --skip-build --optimize=1
install -dm755 "${pkgdir}"/usr/share/licenses/${pkgname}