summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2016-12-22 13:59:30 +0100
committergraziano.giuliani2016-12-22 13:59:30 +0100
commit8e6736ccaf09f4bdedc26be746ac0779ed888831 (patch)
tree9ad70a2c54cdd9b032cd7fab858573d2c57566ae
parent7d022b8542cfcaf9735e70200ce9610417680759 (diff)
downloadaur-8e6736ccaf09f4bdedc26be746ac0779ed888831.tar.gz
use eccodes instead of grib_api
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--setup.cfg35
3 files changed, 47 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ced0a82835bf..abfe65bba5f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Oct 9 10:56:49 UTC 2016
+# Thu Dec 22 12:59:03 UTC 2016
pkgbase = python2-pygrib
pkgdesc = Python module for reading and writing GRIB (editions 1 and 2) files.
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jswhit/pygrib
arch = i686
arch = x86_64
@@ -11,9 +11,11 @@ pkgbase = python2-pygrib
depends = python2-pyproj
depends = jasper
depends = python2-numpy
- depends = grib_api
+ depends = eccodes
source = https://pypi.python.org/packages/source/p/pygrib/pygrib-2.0.1.tar.gz
+ source = setup.cfg
md5sums = e9ae04cb987992691b388b16be53214a
+ md5sums = d5a6f196213d2a53c280c7be1cb1bb03
pkgname = python2-pygrib
diff --git a/PKGBUILD b/PKGBUILD
index 75ed47a1fdc3..a6f1702b6cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Maintainer : Graziano Giuliani <graziano.giuliani@gmail.com>
pkgname=python2-pygrib
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python module for reading and writing GRIB (editions 1 and 2) files."
arch=('i686' 'x86_64')
url="https://github.com/jswhit/pygrib"
license=('MIT')
-depends=('python2-pyproj' 'jasper' 'python2-numpy' 'grib_api')
-source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz)
-md5sums=('e9ae04cb987992691b388b16be53214a')
+depends=('python2-pyproj' 'jasper' 'python2-numpy' 'eccodes')
+source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz setup.cfg)
+md5sums=('e9ae04cb987992691b388b16be53214a'
+ 'd5a6f196213d2a53c280c7be1cb1bb03')
build() {
cd "${srcdir}/pygrib-${pkgver}"
@@ -18,6 +19,8 @@ build() {
export ZLIB_DIR=/usr
export OPENJPEG_DIR=/usr
export GRIBAPI_DIR=/usr
+ cp ${srcdir}/setup.cfg .
+ sed -i 's/image.inmem_.*=.*1;//' g2clib_src/enc_jpeg2000.c
python2 setup.py build
}
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 000000000000..843aa21353bd
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,35 @@
+# Rename this file to setup.cfg to set pygrib's
+# build options.
+# Follow instructions below for editing.
+[directories]
+# uncomment and set to grib_api install location.
+# Include files should be located in grib_api_dir/include and
+# the library should be located in grib_api_dir/lib.
+# If the libraries and include files are installed in separate locations,
+# use grib_api_libdir and grib_api_incdir to specify the locations
+# separately.
+#grib_api_dir = /usr/local
+# if grib_api was built with jasper support for JPEG200,
+# uncomment and set to jasper lib install location.
+# If the libraries and include files are installed in separate locations,
+# use jasper_libdir and jasper_incdir.
+#jasper_dir = /usr/local
+# if grib_api was built with openjpeg support for JPEG200,
+# uncomment and set to openjpeg lib install location.
+# If the libraries and include files are installed in separate locations,
+# use openjpeg_libdir and openjpeg_incdir.
+#openjpeg_dir = /usr/local
+# if grib_api was built with png support,
+# uncomment and set to png lib install location.
+# If the libraries and include files are installed in separate locations,
+# use png_libdir and png_incdir.
+#png_dir = /usr
+# if grib_api was built with png support,
+# uncomment and set to zlib install location.
+#zlib_dir = /usr
+# install man pages for command line utilities here
+#man_dir = /usr/local/man
+[files]
+# uncomment and set to grib_api library name.
+# If you are using GRIB-API with MSVS, library name might be 'grib_api_lib'.
+grib_api_libname = eccodes