summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-03-14 12:42:11 +0000
committerGrey Christoforo2017-03-14 12:42:11 +0000
commit7e59334bc6784a4a2a1dad9c9808fa4829fd1f51 (patch)
tree279055bb90205899cb0a0bf4fbdef638b4b361fb
downloadaur-7e59334bc6784a4a2a1dad9c9808fa4829fd1f51.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef6d68172706
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Mar 14 12:42:06 UTC 2017
+pkgbase = python2-pyina
+ pkgdesc = MPI parallel map and cluster scheduling
+ pkgver = 0.1a1
+ pkgrel = 1
+ url = http://www.cacr.caltech.edu/~mmckerns/pyina.htm
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-dill
+ depends = python2-mpi4py
+ provides = python2-pyina
+ source = https://files.pythonhosted.org/packages/source/p/pyina/pyina-0.1a1.tgz
+ md5sums = e6c3c09d6b86f0a47246348680e35fbf
+
+pkgname = python2-pyina
+ depends = python2
+ depends = python2-dill
+ depends = python2-mpi4py
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6fd264a84d0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tgz
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeb42c0d5765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=('python2-pyina')
+_module='pyina'
+pkgver='0.1a1'
+pkgrel=1
+pkgdesc="MPI parallel map and cluster scheduling"
+url="http://www.cacr.caltech.edu/~mmckerns/pyina.htm"
+depends=('python2' 'python2-dill' 'python2-mpi4py')
+#optdepends=('python2-pyre')
+makedepends=('python2-setuptools')
+provides=('python2-pyina')
+conflics=('python2-pyina-git')
+license=('BSD')
+arch=('any')
+
+source=("https://files.pythonhosted.org/packages/source/p/pyina/pyina-${pkgver}.tgz")
+md5sums=('e6c3c09d6b86f0a47246348680e35fbf')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}