summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2020-02-16 13:09:10 +0100
committerValHue2020-02-16 13:09:10 +0100
commite13cb5503ce43da523738c3cc74bc9922858401d (patch)
tree0a8c2bc457141b6746045241c1cb864844e3fd0b
downloadaur-e13cb5503ce43da523738c3cc74bc9922858401d.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2607792fa45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pyinotify
+ pkgdesc = Python module used for monitoring filesystems events on Linux platforms with inotify.
+ pkgver = 0.9.6
+ pkgrel = 7
+ url = https://github.com/seb-m/pyinotify
+ arch = any
+ license = custom:MIT
+ makedepends = python2
+ depends = python2
+ source = python2-pyinotify-0.9.6.tar.gz::https://github.com/seb-m/pyinotify/archive/0.9.6.tar.gz
+ sha256sums = 7943f198c5cef2bdc121d847937fbe565daaa7d4daaf1b8de8ef5689812f481c
+
+pkgname = python2-pyinotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9884e71def60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+#
+_pkgname="pyinotify"
+pkgname="python2-${_pkgname}"
+pkgver="0.9.6"
+pkgrel="7"
+pkgdesc='Python module used for monitoring filesystems events on Linux platforms with inotify.'
+arch=('any')
+url="https://github.com/seb-m/pyinotify"
+license=('custom:MIT')
+depends=('python2')
+makedepends=('python2')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('7943f198c5cef2bdc121d847937fbe565daaa7d4daaf1b8de8ef5689812f481c')
+
+build() {
+ cd ${_pkgname}-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd ${_pkgname}-$pkgver
+ python2 setup.py install --root=${pkgdir} -O1
+
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 COPYING \
+ ${pkgdir}/usr/share/licenses/${pkgname}
+}
+
+# vim: set ts=4 sw=4 et syn=sh ft=sh: