summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-06-29 12:32:15 +0100
committerFFY002018-06-29 12:32:15 +0100
commit76e2cc67d347bd878551aeeb80d1a61b3a1ddb81 (patch)
tree27869368c6b775136582c2dd8a16de1b2261fc0d
downloadaur-76e2cc67d347bd878551aeeb80d1a61b3a1ddb81.tar.gz
pkgbuild: initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e703540f874
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python2-pyipv8-git
+ pkgdesc = Python implementation of the IPv8 layer
+ pkgver = r417.b3cf77c
+ pkgrel = 1
+ url = https://github.com/Tribler/py-ipv8
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = python2-cryptography
+ depends = python2-libnacl
+ depends = python2-netifaces
+ depends = python2-networkx
+ depends = python2-twisted
+ depends = python2-pyopenssl
+ provides = python2-pyipv8
+ conflicts = python2-pyipv8
+ source = git+https://github.com/Tribler/py-ipv8
+ sha256sums = SKIP
+
+pkgname = python2-pyipv8-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ed189a092d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Filipe LaĆ­ns (FFY00) <filipe.lains@gmail.com>
+pkgname=python2-pyipv8-git
+pkgver=r417.b3cf77c
+pkgrel=1
+pkgdesc="Python implementation of the IPv8 layer"
+arch=(any)
+url="https://github.com/Tribler/py-ipv8"
+license=('Apache')
+depends=('python2-cryptography' 'python2-libnacl' 'python2-netifaces' 'python2-networkx' 'python2-twisted' 'python2-pyopenssl')
+makedepends=('git')
+provides=('python2-pyipv8')
+conflicts=('python2-pyipv8')
+source=("git+$url")
+sha256sums=('SKIP')
+
+_rname=py-ipv8
+
+pkgver() {
+ cd $srcdir/$_rname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/$_rname
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/$_rname
+ python2 setup.py install --root=$pkgdir --optimize=1 --skip-build
+}