summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaesim4042017-01-27 00:47:25 +0200
committerCaesim4042017-01-27 00:48:40 +0200
commit81123505e290772c39d3005dbfa7f73d558e7aa2 (patch)
tree22a06383b36dee42e714c5c93a07559f5c6461ba
downloadaur-81123505e290772c39d3005dbfa7f73d558e7aa2.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..350009b98e64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-pyjsparser
+ pkgdesc = Fast JavaScript parser (based on esprima.js)
+ pkgver = 2.4.5
+ pkgrel = 1
+ url = https://github.com/PiotrDabkowski/pyjsparser
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/p/pyjsparser/pyjsparser-2.4.5.tar.gz
+ source = https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md
+ md5sums = 69a028f632baf7fe79fe2df253cbfd26
+ md5sums = faa744092d3fb3314632e815e7c3a560
+
+pkgname = python2-pyjsparser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b53d1b220d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caesim404 <caesim404 at gmail dot com>
+
+pkgname=python2-pyjsparser
+_pypiname=${pkgname/python2-/}
+pkgver=2.4.5
+pkgrel=1
+pkgdesc="Fast JavaScript parser (based on esprima.js)"
+arch=(any)
+url="https://github.com/PiotrDabkowski/pyjsparser"
+license=(MIT)
+depends=(python2)
+makedepends=(python2-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md")
+md5sums=("69a028f632baf7fe79fe2df253cbfd26"
+ "faa744092d3fb3314632e815e7c3a560")
+
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+
+ cd "${_pypiname}-${pkgver}"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}