summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2019-09-24 19:57:46 +0200
committerJonne Haß2019-09-24 19:57:46 +0200
commitc57599416996c0df73a0276d573282626cb4ff77 (patch)
tree459cc463243a6b7ccb2e22f1ad93eb59808b2775
downloadaur-c57599416996c0df73a0276d573282626cb4ff77.tar.gz
python2-pykeepass: add
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba39414516d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-pykeepass
+ pkgdesc = Python library to interact with keepass databases (supports KDBX3 and KDBX4)
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = https://github.com/pschmitt/pykeepass
+ arch = any
+ license = GPL3
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-construct
+ depends = python2-argon2
+ source = https://files.pythonhosted.org/packages/source/p/pykeepass/pykeepass-3.0.3.tar.gz
+ sha256sums = 2c9e2ddb03ee696ed8aa72c2cddfb81280614864e003226141d68b975aa56f6f
+
+pkgname = python2-pykeepass
+ depends = python2
+ depends = python2-construct
+ depends = python2-argon2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc44e0e62b8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase='python2-pykeepass'
+pkgname=('python2-pykeepass')
+_module='pykeepass'
+pkgver='3.0.3'
+pkgrel=1
+pkgdesc="Python library to interact with keepass databases (supports KDBX3 and KDBX4)"
+url="https://github.com/pschmitt/pykeepass"
+depends=('python2' 'python2-construct' 'python2-argon2')
+makedepends=('python2-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('2c9e2ddb03ee696ed8aa72c2cddfb81280614864e003226141d68b975aa56f6f')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}