summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJimmy Brisson2016-04-19 22:18:12 -0500
committerJimmy Brisson2016-04-19 22:18:12 -0500
commit75e6ef6972a128fc40cc72b2c1530db66ac008da (patch)
tree28175a2595986fc6cba7f17fd3a41a85cba2dff9
parentb4ec56532ac6308f98e418f078fce08578bcde30 (diff)
downloadaur-75e6ef6972a128fc40cc72b2c1530db66ac008da.tar.gz
moved the python lib to the right dir
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3545e31309ae..7ad09de88585 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jimmy Brisson <theotherjimmy@gmail.com>
pkgname=python2-pylc3-git
-pkgrel=1
+pkgrel=2
pkgver=r160.1a4ff2d
pkgdesc="A python and C++ LC-3 simulator"
arch=('any')
@@ -32,4 +32,8 @@ check() {
package() {
cd "$srcdir/${pkgname%-VCS}"
make install DESTDIR=${pkgdir}
+ mkdir -p ${pkgdir}/usr/lib/python2.7/site-packages
+ mv ${pkgdir}/usr/lib/python2.7/dist-packages/pylc3.so ${pkgdir}/usr/lib/python2.7/site-packages/pylc3.so
+ rm ${pkgdir}/usr/lib/libpylc3.so
+ ln -s /usr/lib/python2.7/site-packages/pylc3.so ${pkgdir}/usr/lib/libpylc3.so
}