summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:19:57 +0200
committerM0Rf302015-06-17 16:19:57 +0200
commitfd9c5783c71a3b3268c836f4aa5cabd3b50ef424 (patch)
tree9d85e75ecf65c04575e428030daffac32b2957ce
downloadaur-fd9c5783c71a3b3268c836f4aa5cabd3b50ef424.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--pyleapmouse3
4 files changed, 67 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..75b074315cf3
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pyleapmouse-git
+ pkgdesc = A Leap Motion based mouse in Python.
+ pkgver = 63.97d8839
+ pkgrel = 1
+ url = https://github.com/pythonian4000/PyLeapMouse
+ arch = any
+ license = unknown
+ depends = python2
+ depends = python2-pyuserinput-git
+ depends = leap-motion-sdk
+ source = git+https://github.com/openleap/PyLeapMouse.git
+ source = pyleapmouse
+
+pkgname = python2-pyleapmouse-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b7e797aa01d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-pyleapmouse-git
+ pkgdesc = A Leap Motion based mouse in Python.
+ pkgver = 63.97d8839
+ pkgrel = 1
+ url = https://github.com/pythonian4000/PyLeapMouse
+ arch = any
+ license = unknown
+ depends = python2
+ depends = python2-pyuserinput-git
+ depends = leap-motion-sdk
+ source = git+https://github.com/openleap/PyLeapMouse.git
+ source = pyleapmouse
+ md5sums = SKIP
+ md5sums = e32194507284896d6335364073ed0874
+
+pkgname = python2-pyleapmouse-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a231edbd763f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: M0Rf30
+
+pkgname='python2-pyleapmouse-git'
+pkgver=63.97d8839
+pkgrel=1
+pkgdesc="A Leap Motion based mouse in Python."
+url="https://github.com/pythonian4000/PyLeapMouse"
+arch=('any')
+license=('unknown')
+depends=('python2' 'python2-pyuserinput-git' 'leap-motion-sdk')
+source=('git+https://github.com/openleap/PyLeapMouse.git'
+ 'pyleapmouse')
+
+package() {
+ cd PyLeapMouse
+ rm -r {OSX,Windows,.gitignore}
+ mkdir -p $pkgdir/opt/pyleapmouse
+ cp -r * $pkgdir/opt/pyleapmouse
+ ln -sr /usr/lib/Leap/libLeap.so $pkgdir/opt/pyleapmouse/Linux
+ ln -sr /usr/lib/Leap/Leap.py $pkgdir/opt/pyleapmouse/Linux
+ ln -sr /usr/lib/Leap/LeapPython.so $pkgdir/opt/pyleapmouse/Linux
+ install -Dm644 ../pyleapmouse $pkgdir/usr/bin/pyleapmouse
+ chmod +x $pkgdir/usr/bin/pyleapmouse
+}
+
+pkgver() {
+ cd PyLeapMouse
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP'
+ 'e32194507284896d6335364073ed0874')
diff --git a/pyleapmouse b/pyleapmouse
new file mode 100644
index 000000000000..79f197df3de2
--- /dev/null
+++ b/pyleapmouse
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/pyleapmouse
+python2 PyLeapMouse.py $@