summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 01:59:54 +0200
committerDaniel Milde2017-06-07 14:28:20 +0200
commite96712e4c0c234c8866c0017f90817ced2b83c31 (patch)
treea278b36d89e8e6cb0372217353d7bfefbeb19b87
downloadaur-e96712e4c0c234c8866c0017f90817ced2b83c31.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6faa013d8705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pylint-common
+ pkgdesc = Pylint plugin for augmenting and improving error detection and analysis in the standard Python library
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pylint-common
+ arch = any
+ license = GPL2
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.io/packages/source/p/pylint-common/pylint-common-0.2.5.tar.gz
+ md5sums = 821725a39702815c68558df3059cb176
+
+pkgname = python2-pylint-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b9c6152805c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Daniel Milde <daniel@milde.cz>
+pkgname=python2-pylint-common
+_pkgname=pylint-common
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="Pylint plugin for augmenting and improving error detection and analysis in the standard Python library"
+arch=('any')
+url="https://pypi.python.org/pypi/pylint-common"
+license=('GPL2')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=(https://pypi.io/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
+md5sums=('821725a39702815c68558df3059cb176')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python2 setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}