summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-06-08 08:59:28 -0400
committerAdam Goldsmith2015-06-08 08:59:28 -0400
commitef93d81e3d092606e3327a1f9f5d11360d2f1f49 (patch)
tree9f98c1c61d1e5e6428720443169937a4119b6318
downloadaur-ef93d81e3d092606e3327a1f9f5d11360d2f1f49.tar.gz
migrating to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66ab672c76bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pylru-git
+ pkgdesc = A least recently used (LRU) cache for Python.
+ pkgver = r62.eca0254
+ pkgrel = 1
+ url = https://github.com/jlhutch/pylru
+ arch = any
+ license = GPL
+ depends = python2
+ provides = python2-pylru
+ conflicts = python2-pylru
+ source = git+https://github.com/jlhutch/pylru.git
+ md5sums = SKIP
+
+pkgname = python2-pylru-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc1aa40f5e9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Adam Goldsmith <adam@adamgoldsmith.name>
+pkgname=python2-pylru-git
+pkgver=r62.eca0254
+pkgrel=1
+pkgdesc="A least recently used (LRU) cache for Python."
+arch=('any')
+url="https://github.com/jlhutch/pylru"
+license=('GPL')
+depends=(python2)
+provides=(python2-pylru)
+conflicts=(python2-pylru)
+source=('git+https://github.com/jlhutch/pylru.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pylru
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/pylru"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: