summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuikai Liu2018-09-05 14:36:52 +0800
committerRuikai Liu2018-09-05 14:36:52 +0800
commit37dafb55ca1fdaeb113dbeaa1884c1364c925974 (patch)
treec38e648756d975e0f1d16efbf57fc94a6a124a8d
parent4d351a54b92218de2469a71cbc3ee37d45f5f1f6 (diff)
downloadaur-37dafb55ca1fdaeb113dbeaa1884c1364c925974.tar.gz
user prebuilt binaries
-rw-r--r--PKGBUILD41
1 files changed, 26 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e58c6d0747f..5276e75168e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,31 @@
-# Maintainer: Ruikai Liu <lrk700@gmail.com>
-pkgname=python2-pymupdf
+# Maintainer: Ruikai Liu <lrk700 at gmail dot com>
+# Contributor: Alexander Kobel <a-kobel at a-kobel dot de>
+
_pkgname=PyMuPDF
-pkgver=1.9.1
+pkgname=('python2-pymupdf' 'python-pymupdf')
+pkgver=1.13.19
pkgrel=1
-pkgdesc="Python bindings for MuPDF"
-arch=('any')
-url="https://github.com/rk700/PyMuPDF"
-license=('GPL3')
-depends=('python2' 'libmupdf')
-makedepends=('swig')
-source=("https://github.com/rk700/PyMuPDF/archive/v1.9.1.zip")
-md5sums=("27b8e869b9ca995ca505ebeba5b4557b")
+pkgdesc='Python bindings for MuPDF'
+arch=('x86_64')
+url='https://github.com/rk700/PyMuPDF'
+license=('AGPL3')
+depends=('python2>=2.7' 'python2<2.8')
+makedepends=('python2-pip' 'python-pip')
+
+source=("${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}-cp27-cp27mu-manylinux1_x86_64.whl"
+"${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}-cp37-cp37m-manylinux1_x86_64.whl")
+noextract=("${_pkgname}-${pkgver}-cp27-cp27mu-manylinux1_x86_64.whl"
+ "${_pkgname}-${pkgver}-cp37-cp37m-manylinux1_x86_64.whl")
+sha256sums=('6ce0975bc644c3153fd4d58e33085608106f80a3776ecc09cf3f72b716ddf89f'
+'c18f8ee416bf261ef54bfafb8a4e76f140ad65a34e9b27601a610118a6bf96e3')
-package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python2 setup.py install --root=$pkgdir
+package_python2-pymupdf() {
+ cd "${srcdir}"
+ pip2 install --root="${pkgdir}" "${_pkgname}-${pkgver}-cp27-cp27mu-manylinux1_x86_64.whl"
}
-# vim:set ts=4 sw=4 sts=4 et:
+package_python-pymupdf() {
+ depends=('python>=3.7' 'python<3.8')
+ cd "${srcdir}"
+ pip install --root="${pkgdir}" "${_pkgname}-${pkgver}-cp37-cp37m-manylinux1_x86_64.whl"
+}