summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2015-06-25 20:01:44 -0600
committerBenjamin A. Shelton2015-06-25 20:01:44 -0600
commitb8b35125d2837cafdd3e8a2a49172ec0ea1ed87c (patch)
tree032b64a8cc370a91cfc81d0495ba35c358eddb51
downloadaur-b8b35125d2837cafdd3e8a2a49172ec0ea1ed87c.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e7201763687
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-pynliner
+ pkgdesc = Python CSS-to-inline-styles conversion tool for HTML using BeautifulSoup and cssutils.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pynliner
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-beautifulsoup4
+ depends = python2-cssutils
+ source = https://pypi.python.org/packages/source/p/pynliner/pynliner-0.5.2.tar.gz
+ md5sums = 5a0b85aa5448c8f8d14fb58e5ab1c3c1
+
+pkgname = python2-pynliner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f56a948366bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Benjamin A. Shelton <zancarius@gmail.com>
+# Source: https://github.com/zancarius/archlinux-pkgbuilds
+
+pkgname=python2-pynliner
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="Python CSS-to-inline-styles conversion tool for HTML using BeautifulSoup and cssutils."
+arch=(any)
+url="http://pypi.python.org/pypi/pynliner"
+
+# It's necessary to dig around for it a bit, but the license is found at
+# the project's Github page: https://github.com/rennat/pynliner
+license=(MIT)
+depends=(python2 python2-beautifulsoup4 python2-cssutils)
+makedepends=(python2-setuptools)
+source=("https://pypi.python.org/packages/source/p/pynliner/pynliner-${pkgver}.tar.gz")
+md5sums=(5a0b85aa5448c8f8d14fb58e5ab1c3c1)
+
+package () {
+
+ cd "${srcdir}/pynliner-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+}