summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-30 16:47:56 +0200
committerMarcell Meszaros2022-06-30 16:47:56 +0200
commit99cfd655036f21d66583e95ea9029c76022f75cf (patch)
treefae2be0c913b510679497524854608e1aa586458
parent30791904c8581cbd55fcf6ba5ecca218dca62cb9 (diff)
downloadaur-99cfd655036f21d66583e95ea9029c76022f75cf.tar.gz
21.0.0-5: skip one path test: might fail in modified environments (like when using paru)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6544432973c..907b2f35d7f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-pyopenssl
pkgdesc = Wrapper module for OpenSSL, legacy Python 2 version
pkgver = 21.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://pypi.org/project/pyopenssl/21.0.0/
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 98b314c0afa9..0f845a46e22c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='python2-pyopenssl'
_name="${pkgname#python2-}"
pkgver=21.0.0
-pkgrel=4
+pkgrel=5
pkgdesc='Wrapper module for OpenSSL, legacy Python 2 version'
arch=('any')
url="https://pypi.org/project/${_name}/${pkgver}/"
@@ -46,8 +46,15 @@ build() {
check() {
cd "${_tarname}"
echo 'Running tests...'
- echo '-- Using LC_ALL=C.UTF-8 locale to ensure UTF-8 filesystem encoding is used in Python 2'
- LC_ALL=C.UTF-8 python2 setup.py pytest
+
+ (
+ echo '-- Using LC_ALL=C.UTF-8 locale to ensure UTF-8 filesystem encoding is used in Python 2'
+ export LC_ALL=C.UTF-8
+ export PYTHONDONTWRITEBYTECODE=1
+
+ python2 setup.py pytest --addopts \
+ "--deselect tests/test_ssl.py::TestContext::test_fallback_default_verify_paths"
+ )
}
package() {