summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-11-27 19:23:04 +0100
committer0x9fff002020-11-27 19:23:04 +0100
commit9ac8afd764c1be0470b469c742086455acbda1cf (patch)
tree18d548072253a758347e005a1dbb820ae2d76bd1
downloadaur-9ac8afd764c1be0470b469c742086455acbda1cf.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore27
-rw-r--r--.gitignore_append1
-rw-r--r--PKGBUILD42
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..500f33de5906
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-pypandoc
+ pkgdesc = Thin wrapper for pandoc
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/bebraw/pypandoc
+ arch = any
+ license = MIT
+ checkdepends = texlive-core
+ checkdepends = texlive-latexextra
+ checkdepends = pandoc-citeproc
+ makedepends = python2-setuptools
+ makedepends = pandoc
+ depends = python2-setuptools
+ depends = pandoc
+ source = python2-pypandoc-1.5.tar.gz::https://github.com/bebraw/pypandoc/archive/1.5.tar.gz
+ sha512sums = bc1a18115827ac0868b887fa3c9be46736670de8f095cb49b444e61f66779497db9a08bdac0de30f821a64cd6bad195f1d3a29d0159e6e3ad050a78ca0ecea82
+
+pkgname = python2-pypandoc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f12030797c07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..a92184e5a9bf
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1 @@
+# archlinuxpackages linux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbfabaa0d5be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+
+# Based on python-pypandoc in [community]
+
+_name=pypandoc
+pkgname=python2-$_name
+pkgver=1.5
+pkgrel=1
+pkgdesc='Thin wrapper for pandoc'
+arch=('any')
+url="https://github.com/bebraw/$_name"
+license=('MIT')
+depends=('python2-setuptools' 'pandoc')
+makedepends=('python2-setuptools' 'pandoc')
+checkdepends=('texlive-core' 'texlive-latexextra' 'pandoc-citeproc')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('bc1a18115827ac0868b887fa3c9be46736670de8f095cb49b444e61f66779497db9a08bdac0de30f821a64cd6bad195f1d3a29d0159e6e3ad050a78ca0ecea82')
+
+prepare() {
+ # We don't really need pip and wheel at runtime
+ sed -i "s/install_requires = .*/install_requires = ['setuptools'],/" $_name-$pkgver/setup.py
+}
+
+build() {
+ cd $_name-$pkgver
+
+ python2 setup.py build
+}
+
+check() {
+ cd $_name-$pkgver
+
+ python2 setup.py test
+}
+
+package() {
+ cd $_name-$pkgver
+
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}