summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2016-03-01 12:45:07 -0500
committerAdam Goldsmith2016-03-01 12:45:07 -0500
commitf4305c48e78871b5abc3687e5397c8c193892aa1 (patch)
tree0e6630ff4efc4afca767cb5704cbf9315aee5c22
downloadaur-f4305c48e78871b5abc3687e5397c8c193892aa1.tar.gz
Initial Commit
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e23ef98764b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Tue Mar 1 17:43:06 UTC 2016
+pkgbase = python2-pypkjs-git
+ pkgdesc = Python implementation of PebbleKit JS
+ pkgver = v1.0
+ pkgrel = 1
+ url = https://github.com/pebble/pypkjs
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = python2-libpebble2-git
+ depends = python2-backports.ssl_match_hostname
+ depends = python2-gevent
+ depends = python2-gevent-websocket
+ depends = python2-greenlet
+ depends = python2-peewee
+ depends = python2-pygeoip
+ depends = python2-pypng
+ depends = python2-dateutil
+ depends = python2-requests
+ depends = python2-sh
+ depends = python2-six
+ depends = python2-websocket-client
+ depends = python2-wsgiref
+ depends = python2-netaddr
+ provides = python2-pypkjs
+ conflicts = python2-pypkjs
+ source = git+https://github.com/pebble/pypkjs.git
+ md5sums = SKIP
+
+pkgname = python2-pypkjs-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b4de7601b350
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pypkjs/
+/pkg/
+/src/
+*.pkg.tar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cae9024e2637
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+pkgname=python2-pypkjs-git
+pkgver=v1.0
+pkgrel=1
+pkgdesc="Python implementation of PebbleKit JS"
+arch=('i686' 'x86_64')
+url="https://github.com/pebble/pypkjs"
+license=('GPL')
+depends=('python2'
+ 'python2-libpebble2-git'
+ 'python2-backports.ssl_match_hostname'
+ 'python2-gevent'
+ 'python2-gevent-websocket'
+ 'python2-greenlet'
+ 'python2-peewee'
+ 'python2-pygeoip'
+ 'python2-pypng'
+ 'python2-dateutil'
+ 'python2-requests'
+ 'python2-sh'
+ 'python2-six'
+ 'python2-websocket-client'
+ 'python2-wsgiref'
+ 'python2-netaddr')
+provides=('python2-pypkjs')
+conflicts=('python2-pypkjs')
+source=("git+https://github.com/pebble/pypkjs.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pypkjs"
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/pypkjs"
+ git submodule update --init --recursive
+}
+
+package() {
+ cd "$srcdir/pypkjs"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -dm755 "$pkgdir/usr/bin/"
+ install -m755 "phonesim.py" "$pkgdir/usr/bin/"
+}
+
+# vim:set ts=2 sw=2 et: