summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2014-04-28 18:58:59 +0200
committerFlorian Bruhin2014-04-28 18:58:59 +0200
commit708186b757d378e62a1f6dcabd204f996036f879 (patch)
treeffa5ecd217fc26ad00efdccb3cd4f42237656fea
downloadaur-708186b757d378e62a1f6dcabd204f996036f879.tar.gz
Add python2-pypng
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d12af6218328
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pypng
+ pkgdesc = Python 2 module to decode and encode PNG files
+ pkgver = 0.0.16
+ pkgrel = 1
+ url = https://github.com/drj11/pypng
+ arch = any
+ license = MIT
+ makedepends = python2
+ depends = python2
+ source = https://github.com/drj11/pypng/archive/pypng-0.0.16.tar.gz
+ sha1sums = 656da1a46b82689154760b1863d3677472321c39
+
+pkgname = python2-pypng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbfe69222c4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+# Contributor: Beej Jorgensen <beej@beej.us>
+
+pkgname=python2-pypng
+pkgver=0.0.16
+pkgrel=1
+pkgdesc="Python 2 module to decode and encode PNG files"
+arch=('any')
+url="https://github.com/drj11/pypng"
+license=('MIT')
+depends=('python2')
+makedepends=('python2')
+source=(https://github.com/drj11/pypng/archive/pypng-${pkgver}.tar.gz)
+sha1sums=('656da1a46b82689154760b1863d3677472321c39')
+
+package() {
+ cd "$srcdir/pypng-pypng-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: