summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2020-04-22 12:55:57 -0300
committerRenato Lui Geh2020-04-22 12:57:34 -0300
commitd084dc72e6aa656eb7ebd29b4bd460d6b24313a8 (patch)
tree193edd4f252a706de109c52d636d1473354365af
downloadaur-d084dc72e6aa656eb7ebd29b4bd460d6b24313a8.tar.gz
PyPSDD 0.1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1933f9d3958e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pypsdd
+ pkgdesc = The Python Probabilistic Sentential Decision Diagrams (PSDD) Package.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/art-ai/pypsdd
+ arch = any
+ license = Apache 2.0
+ makedepends = git
+ depends = python2
+ optdepends = pypy
+ source = git+https://github.com/art-ai/pypsdd
+ sha256sums = SKIP
+
+pkgname = python2-pypsdd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73c466425a55
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.gz
+*.tar.xz
+clean.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db303350f835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Renato Lui Geh <renatogeh at gmail dot com>
+
+pkgname=python2-pypsdd
+_gitname="pypsdd"
+pkgver=0.1
+pkgrel=1
+pkgdesc="The Python Probabilistic Sentential Decision Diagrams (PSDD) Package."
+arch=('any')
+url="https://github.com/art-ai/pypsdd"
+license=('Apache 2.0')
+depends=('python2')
+optdepends=('pypy')
+makedepends=('git')
+source=("git+https://github.com/art-ai/pypsdd")
+sha256sums=('SKIP')
+
+build() {
+ cd "$_gitname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$_gitname"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+