summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-06-13 16:04:24 +0200
committerMarco Pompili2015-06-13 16:04:24 +0200
commit6007a61d86f2c4ab42347a68e2c1d82321be214a (patch)
tree4e988e19f8363432d9eade55c240d6f73de90c4f
downloadaur-6007a61d86f2c4ab42347a68e2c1d82321be214a.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD17
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3dd6c67f6583
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python2-pyraf
+ pkgdesc = Python interface for IRAF
+ pkgver = 2.1.7
+ pkgrel = 1
+ url = http://www.stsci.edu/institute/software_hardware/pyraf/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python2
+ depends = python2-stscitools
+ depends = iraf-bin
+ depends = python2-matplotlib
+ depends = python2-numpy
+ depends = python2-urwid
+ depends = tcl
+ depends = tk
+ optdepends = ipython2
+ source = http://stsdas.stsci.edu/download/pyraf/pyraf-2.1.7.tar.gz
+ md5sums = 72c7529de63bd1d4cfe016e5253d0b8f
+
+pkgname = python2-pyraf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18a7339f5f01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Christian Dersch <chrisdersch@gmail.com>
+pkgname=python2-pyraf
+pkgver=2.1.7
+pkgrel=1
+pkgdesc="Python interface for IRAF"
+arch=('i686' 'x86_64')
+depends=('python2' 'python2-stscitools' 'iraf-bin' 'python2-matplotlib' 'python2-numpy' 'python2-urwid' 'tcl' 'tk')
+optdepends=('ipython2')
+url="http://www.stsci.edu/institute/software_hardware/pyraf/"
+source=(http://stsdas.stsci.edu/download/pyraf/pyraf-$pkgver.tar.gz)
+license=('BSD')
+md5sums=('72c7529de63bd1d4cfe016e5253d0b8f')
+
+package() {
+ cd $srcdir/pyraf-$pkgver
+ python2 setup.py install --root $pkgdir
+}