summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Torres2017-02-10 18:41:15 +0100
committerJavier Torres2017-02-10 18:41:15 +0100
commited540b644b4850675637f9c92383acc47aa47af4 (patch)
treeb336c55d87d528a8a2d605d20ccdc5fde04b106e
downloadaur-ed540b644b4850675637f9c92383acc47aa47af4.tar.gz
Initial release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5362006b3fc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 10 17:41:07 UTC 2017
+pkgbase = python2-pysal
+ pkgdesc = Cross-platform library of spatial analysis functions
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = http://pysal.org/
+ arch = any
+ license = BSD
+ depends = python2
+ depends = python2-setuptools
+ depends = python2-scipy
+ depends = python2-numpy
+ options = !emptydirs
+ source = https://github.com/pysal/pysal/archive/v1.13.0.tar.gz
+ sha256sums = d4336a3eab927ef17b5375a77c41498fd8edfcfd88eb8e2ae687c41714c2b6cb
+
+pkgname = python2-pysal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50c9b06d31fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Javier Torres <jtorres@carto.com>
+pkgname=python2-pysal
+pkgver=1.13.0
+pkgrel=1
+pkgdesc='Cross-platform library of spatial analysis functions'
+arch=('any')
+url='http://pysal.org/'
+license=('BSD')
+depends=('python2' 'python2-setuptools' 'python2-scipy' 'python2-numpy')
+options=(!emptydirs)
+source=("https://github.com/pysal/pysal/archive/v${pkgver}.tar.gz")
+sha256sums=('d4336a3eab927ef17b5375a77c41498fd8edfcfd88eb8e2ae687c41714c2b6cb')
+
+package() {
+ cd "${srcdir}/pysal-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}