summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2015-06-18 12:06:55 +0200
committerFabio Zanini2015-06-18 12:06:55 +0200
commit0668ba9285a4bbc02665b74c11bc627edcf5c909 (patch)
tree7fec810458dee3c04d6d33fa45cb8dd9ac446d4e
downloadaur-0668ba9285a4bbc02665b74c11bc627edcf5c909.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4df728db1cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-pysam
+ pkgdesc = Python interface for the SAM/BAM sequence alignment and mapping format
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://github.com/pysam-developers/pysam
+ arch = x86_64
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = cython2>=0.22
+ depends = python2
+ provides = python2-pysam
+ options = !emptydirs
+ source = https://github.com/pysam-developers/pysam/archive/v0.8.3.tar.gz
+ md5sums = 5ea56c66c3890fef2dc31fc005182f72
+
+pkgname = python2-pysam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab61aa435d12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Fabio Zanini <fabio.zanini _at_ tuebingen.mpg.de>
+pkgname='python2-pysam'
+pkgver=0.8.3
+pkgrel=1
+pkgdesc="Python interface for the SAM/BAM sequence alignment and mapping format"
+arch=('x86_64')
+url="https://github.com/pysam-developers/pysam"
+license=('MIT')
+groups=()
+depends=('python2')
+makedepends=('python2-setuptools' 'cython2>=0.22')
+provides=('python2-pysam')
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://github.com/pysam-developers/pysam/archive/v${pkgver}.tar.gz")
+md5sums=('5ea56c66c3890fef2dc31fc005182f72')
+
+package() {
+ cd "$srcdir/pysam-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: