summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-06-04 14:03:34 +1000
committerJustin Dray2015-06-04 14:03:34 +1000
commit36511a748ff7babe0d02d635007758ed4ac37775 (patch)
treebdc0ad1702b59a4b5f0b457e54f50b6940dfeb1c
downloadaur-python2-pysensors.tar.gz
Fixed to use lowercase name
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0ccb74c134a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-pysensors
+ pkgdesc = Python bindings to libsensors (via ctypes)
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://bitbucket.org/blackjack/pysensors/
+ arch = any
+ license = Apache
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = lm_sensors
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/P/PySensors/PySensors-0.0.3.tar.gz
+ sha256sums = b735dada5318ce50f2d141d29b102e7a116a5934509583f86302d4b59399e961
+
+pkgname = python2-pysensors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55ff14ed7ece
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Justin Dray <justin@dray.be>
+
+_pkgname=PySensors
+pkgname=python2-pysensors
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Python bindings to libsensors (via ctypes)"
+arch=('any')
+depends=('python2' 'lm_sensors')
+makedepends=('python2-setuptools')
+url="https://bitbucket.org/blackjack/pysensors/"
+license=('Apache' 'MIT')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('b735dada5318ce50f2d141d29b102e7a116a5934509583f86302d4b59399e961')
+
+build() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}