summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-06-28 20:29:29 +0200
committerGabriel Souza Franco2018-06-28 20:29:29 +0200
commit06552ef0b6225d7b5b919502f7d291908bf488c2 (patch)
tree5ba0fd09988e67eff415e4ccc31520d3b3a927d3
downloadaur-06552ef0b6225d7b5b919502f7d291908bf488c2.tar.gz
Re-add dropped package needed for freecad
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD52
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3f9a2fde6d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = python2-pyside2
+ pkgdesc = Enables the use of Qt5 APIs in Python applications
+ pkgver = 5.11.0
+ pkgrel = 2
+ url = http://qt-project.org/
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = LGPL
+ makedepends = shiboken2
+ makedepends = python2-shiboken2
+ makedepends = cmake
+ makedepends = qt5-multimedia
+ makedepends = qt5-tools
+ makedepends = qt5-sensors
+ makedepends = qt5-charts
+ makedepends = qt5-webengine
+ makedepends = qt5-datavis3d
+ makedepends = qt5-websockets
+ makedepends = qt5-speech
+ makedepends = qt5-3d
+ makedepends = qt5-svg
+ makedepends = qt5-script
+ makedepends = qt5-scxml
+ makedepends = qt5-x11extras
+ depends = python2-shiboken2
+ depends = qt5-base
+ optdepends = qt5-svg: QtSvg bindings
+ optdepends = qt5-script: QtScript bindings
+ optdepends = qt5-speech: QtTextToSpeech bindings
+ optdepends = qt5-websockets: QtWebSockets bindings
+ optdepends = qt5-webengine: QtWebEngine bindings
+ optdepends = qt5-datavis3d: QtDataVisualization bindings
+ optdepends = qt5-scxml: QtScxml bindings
+ optdepends = qt5-sensors: QtSensors bindings
+ optdepends = qt5-3d: Qt3D bindings
+ optdepends = qt5-x11extras: QtX11Extras bindings
+ optdepends = qt5-charts: QtCharts bindings
+ optdepends = qt5-tools: QtHelp bindings
+ source = http://download.qt.io/official_releases/QtForPython/pyside2/PySide2-5.11.0-src/pyside-setup-everywhere-src-5.11.0.tar.xz
+ sha256sums = fbc412c4544bca308291a08a5173a949ca530d801f00b8337902a5067e490922
+
+pkgname = python2-pyside2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a482fd1a6db9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pyside-setup-*
+*pkg*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44c67e8e8e77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Gabriel Souza Franco <Z2FicmllbGZyYW5jb3NvdXphQGdtYWlsLmNvbQ==>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python2-pyside2
+_qtver=5.11.0
+pkgver=${_qtver/-/}
+pkgrel=2
+arch=(x86_64)
+url='http://qt-project.org/'
+license=(LGPL)
+pkgdesc='Enables the use of Qt5 APIs in Python applications'
+depends=(python2-shiboken2 qt5-base)
+optdepends=('qt5-svg: QtSvg bindings'
+ 'qt5-script: QtScript bindings'
+ 'qt5-speech: QtTextToSpeech bindings'
+ 'qt5-websockets: QtWebSockets bindings'
+ 'qt5-webengine: QtWebEngine bindings'
+ 'qt5-datavis3d: QtDataVisualization bindings'
+ 'qt5-scxml: QtScxml bindings'
+ 'qt5-sensors: QtSensors bindings'
+ 'qt5-3d: Qt3D bindings'
+ 'qt5-x11extras: QtX11Extras bindings'
+ 'qt5-charts: QtCharts bindings'
+ 'qt5-tools: QtHelp bindings')
+makedepends=(shiboken2 python2-shiboken2 cmake
+ qt5-multimedia qt5-tools qt5-sensors qt5-charts qt5-webengine qt5-datavis3d
+ qt5-websockets qt5-speech qt5-3d qt5-svg qt5-script qt5-scxml qt5-x11extras)
+groups=(qt qt5)
+_pkgfqn=pyside-setup-everywhere-src-${_qtver}
+source=("http://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz")
+sha256sums=('fbc412c4544bca308291a08a5173a949ca530d801f00b8337902a5067e490922')
+
+build() {
+ mkdir -p build
+ cd build
+
+ cmake ../${_pkgfqn}/sources/pyside2 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=2
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ # Provided in pyside2
+ rm -r "$pkgdir"/usr/{include,share,lib/{pkgconfig,cmake/*/PySide2Config{.cmake,Version.cmake}}}
+}
+