summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuís Ferreira2018-04-29 17:38:51 +0100
committerLuís Ferreira2018-04-29 17:38:51 +0100
commit31e30fdb906ed96519cbdec65a138c6c05697518 (patch)
tree49926095bf1c31ecd4e03899e872f543dcdb9c05
downloadaur-31e30fdb906ed96519cbdec65a138c6c05697518.tar.gz
Initial files
Signed-off-by: Luís Ferreira <lsferreira169@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..424a3fdff8b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pysmb
+ pkgdesc = An experimental SMB/CIFS library written in Python to support file sharing between Windows and Linux machines.
+ pkgver = 1.1.22
+ pkgrel = 1
+ url = https://miketeo.net/wp/index.php/projects/pysmb
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/be/83/0356cbb096e2934cd01f8049212f16cde114bbe19c7839f795255c741969/pysmb-1.1.22.zip
+ sha1sums = e64c247bf69925b2eaf08472e08fc990d3cfe00d
+
+pkgname = python2-pysmb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02ec3d6bb4b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luís Ferreira <contact@lsferreira.net>
+# Contributor: Levon 'noptrix' Kayan <noptrix@nullsecurity.net>
+
+# This file is part of BlackArch Linux ( http://blackarch.org ).
+# See COPYING for license details.
+
+pkgname='python2-pysmb'
+pkgver='1.1.22'
+pkgrel=1
+pkgdesc='An experimental SMB/CIFS library written in Python to support file sharing between Windows and Linux machines.'
+arch=('any')
+url='https://miketeo.net/wp/index.php/projects/pysmb'
+license=('GPL')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/be/83/0356cbb096e2934cd01f8049212f16cde114bbe19c7839f795255c741969/pysmb-${pkgver}.zip")
+sha1sums=('e64c247bf69925b2eaf08472e08fc990d3cfe00d')
+
+build(){
+ cd "$srcdir/pysmb-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/pysmb-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+} \ No newline at end of file