summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitbdc450b73f677ba3ded9d7ab68fb937c4b52f4e9 (patch)
treee55ac9eb73772a30ef20c60421059f1a88d6a8f4
downloadaur-bdc450b73f677ba3ded9d7ab68fb937c4b52f4e9.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31d7f536d6e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pysodium
+ pkgdesc = Python wrapper for libsodium
+ pkgver = 0.6.6
+ pkgrel = 1
+ url = https://github.com/stef/pysodium
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = libsodium
+ depends = python2
+ depends = python2-cffi
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/pysodium/pysodium-0.6.6.tar.gz
+ md5sums = efaecb87a9ecb2dc6ea40a22649cf629
+ sha256sums = c06fcd5f741962492e9778f4106131c88d703adbb6448cf60441230e298477c8
+
+pkgname = python2-pysodium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fef9f1e2e62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-pysodium
+pkgver=0.6.6
+pkgrel=1
+pkgdesc="Python wrapper for libsodium"
+arch=('any')
+depends=('libsodium' 'python2' 'python2-cffi')
+makedepends=('python2-setuptools')
+url="https://github.com/stef/pysodium"
+license=('BSD')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/p/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('efaecb87a9ecb2dc6ea40a22649cf629')
+sha256sums=('c06fcd5f741962492e9778f4106131c88d703adbb6448cf60441230e298477c8')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}