summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:20:29 +0200
committerM0Rf302015-06-17 16:20:29 +0200
commit8cb5001b3f6f86fe54bc1a7573ec5c901204730a (patch)
tree738e8f0a7367fe98ddc25fb275e67877c216e6be
downloadaur-8cb5001b3f6f86fe54bc1a7573ec5c901204730a.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
3 files changed, 49 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..383913a4597e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pysqlcipher
+ pkgdesc = Python interface to SQLCipher
+ pkgver = 2.6.4
+ pkgrel = 1
+ url = http://github.com/leapcode/pysqlcipher/
+ arch = any
+ license = ZLIB
+ depends = python2
+ depends = sqlcipher
+ source = https://pypi.python.org/packages/source/p/pysqlcipher/pysqlcipher-2.6.4.tar.gz
+ md5sums = d0d03064ee657dca58abdc7860277939
+
+pkgname = python2-pysqlcipher
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..383913a4597e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pysqlcipher
+ pkgdesc = Python interface to SQLCipher
+ pkgver = 2.6.4
+ pkgrel = 1
+ url = http://github.com/leapcode/pysqlcipher/
+ arch = any
+ license = ZLIB
+ depends = python2
+ depends = sqlcipher
+ source = https://pypi.python.org/packages/source/p/pysqlcipher/pysqlcipher-2.6.4.tar.gz
+ md5sums = d0d03064ee657dca58abdc7860277939
+
+pkgname = python2-pysqlcipher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c3321088b87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: M0Rf30
+
+pkgname=python2-pysqlcipher
+pkgver=2.6.4
+pkgrel=1
+pkgdesc="Python interface to SQLCipher"
+arch=(any)
+url="http://github.com/leapcode/pysqlcipher/"
+license=('ZLIB')
+depends=(python2 sqlcipher)
+makedeps=(wget)
+source=(https://pypi.python.org/packages/source/p/pysqlcipher/pysqlcipher-${pkgver}.tar.gz)
+
+
+package(){
+ cd $srcdir/pysqlcipher-${pkgver}
+
+ python2 setup.py install --root="$pkgdir"
+}
+
+md5sums=('d0d03064ee657dca58abdc7860277939')