summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2015-06-09 12:17:52 +0200
committerDaniel Milde2015-06-09 12:17:52 +0200
commitde546f99497d755f8213361444458e2680c0080c (patch)
tree67bcb48b79b3d3b3081646fa9cf687dd25f61322
downloadaur-de546f99497d755f8213361444458e2680c0080c.tar.gz
initial
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rw-r--r--setup.cfg5
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9d391c34e6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.0
+# Sat Jan 24 11:25:42 UTC 2015
+pkgbase = python-pysqlite
+ pkgdesc = A Python DB-API 2.0 interface for the SQLite embedded relational database engine
+ pkgver = 2.6.3
+ pkgrel = 4
+ url = https://pypi.python.org/pypi/pysqlite
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = python2
+ depends = sqlite
+ conflicts = python-pysqlite<=2.6.3-2
+ replaces = python-pysqlite<=2.6.3-2
+ source = https://pypi.python.org/packages/source/p/pysqlite/pysqlite-2.6.3.tar.gz
+ source = setup.cfg
+ md5sums = 7ff1cedee74646b50117acff87aa1cfa
+ md5sums = 86dd356c65afd14a22f2f8f64a26441e
+
+pkgname = python2-pysqlite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87920c4e0c96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgbase=python-pysqlite
+pkgname=python2-pysqlite
+pkgver=2.6.3
+pkgrel=5
+pkgdesc="A Python DB-API 2.0 interface for the SQLite embedded relational database engine"
+license=('custom')
+arch=('any')
+url="https://pypi.python.org/pypi/pysqlite"
+depends=('python2' 'sqlite')
+conflicts=('python-pysqlite<=2.6.3-2')
+replaces=('python-pysqlite<=2.6.3-2')
+source=(https://pypi.python.org/packages/source/p/pysqlite/pysqlite-${pkgver}.tar.gz
+ setup.cfg)
+md5sums=('7ff1cedee74646b50117acff87aa1cfa'
+ '86dd356c65afd14a22f2f8f64a26441e')
+
+prepare() {
+ cp "${srcdir}/setup.cfg" pysqlite-${pkgver}
+}
+
+build() {
+ cd pysqlite-${pkgver}
+ python2 setup.py build
+}
+
+check() {
+ cd pysqlite-${pkgver}/build/lib.*/
+ python2 -c "from pysqlite2 import test; test.test()"
+}
+
+package_python2-pysqlite() {
+ cd pysqlite-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -r "${pkgdir}/usr/pysqlite2-doc"
+}
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 000000000000..ba6c77075682
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,5 @@
+[build_ext]
+define=
+include_dirs=/usr/include
+library_dirs=/usr/lib
+libraries=sqlite3