summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNBonaparte2018-04-12 00:47:34 -0700
committerNBonaparte2018-04-12 00:47:34 -0700
commit5cb2ff83d3d9e8ad3e190aeeef15f4103f1e4d51 (patch)
tree69046e1fce596d80f15e1b59c620c7d68b395914
downloadaur-5cb2ff83d3d9e8ad3e190aeeef15f4103f1e4d51.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bd48d06a4d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-pystache
+ pkgdesc = The mustache template engine written in python
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://github.com/defunkt/pystache
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-setuptools
+ provides = python2-pystache
+ conflicts = python2-pystache
+ source = https://pypi.python.org/packages/source/p/pystache/pystache-0.5.4.tar.gz
+ md5sums = 485885e67a0f6411d5252e69b20a35ca
+
+pkgname = python2-pystache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e332cb4cdcb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Florian Klink <flokli at flokli dot de>
+
+_python=python2
+_distname=pystache
+pkgname=$_python-$_distname
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="The mustache template engine written in python"
+arch=(any)
+url="http://github.com/defunkt/pystache"
+license=('MIT')
+depends=('python2' 'python2-setuptools')
+provides=('python2-pystache')
+conflicts=('python2-pystache')
+source=( "https://pypi.python.org/packages/source/${_distname:0:1}/$_distname/$_distname-$pkgver.tar.gz")
+md5sums=('485885e67a0f6411d5252e69b20a35ca')
+
+package() {
+ cd "$srcdir/$_distname-$pkgver"
+ $_python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || exit 1
+}