summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:36:06 +0200
committerDaniel Nagy2015-06-08 20:36:06 +0200
commit979bc5565b94728cbd4e46969141f6163d49b879 (patch)
tree70b57c0eba92dcddf2590362d708b44304b2f231
downloadaur-979bc5565b94728cbd4e46969141f6163d49b879.tar.gz
import to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b89505e9f2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-pystache-git
+ pkgdesc = The mustache template engine written in python
+ pkgver = 1057.6a54b9a
+ pkgrel = 2
+ url = https://github.com/defunkt/pystache
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ provides = python2-pystache
+ conflicts = python2-pystache
+ source = git+https://github.com/defunkt/pystache
+ md5sums = SKIP
+
+pkgname = python2-pystache-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bf1671c9316
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Tom Vincent <http://tlvince.com/contact/>
+# Contributor: Tyler Harper <tyler@cowboycoding.net>
+
+_gitname=pystache
+pkgname=python2-pystache-git
+pkgver=1057.6a54b9a
+pkgrel=2
+pkgdesc="The mustache template engine written in python"
+arch=(any)
+url="https://github.com/defunkt/pystache"
+license=('MIT')
+depends=('python2')
+makedepends=('git')
+provides=('python2-pystache')
+conflicts=('python2-pystache')
+source=( "git+$url" )
+md5sums=( 'SKIP' )
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # Use the tag of the last commit
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}