summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Seemayer2015-07-06 10:11:50 +0200
committerStefan Seemayer2015-07-06 10:11:50 +0200
commitb4c645f7df9cd9a6a8551c5b55f4a99a62bf3d4b (patch)
tree89a457f2b30d5db0e26d4a4df7fb1b7c6b6dd926
downloadaur-python2-pysvmlight-hg.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a07f07f9458
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-pysvmlight-hg
+ pkgdesc = A Python binding to the SVMlight support vector machine library by Thorsten Joachims
+ pkgver = 20130415
+ pkgrel = 1
+ url = https://bitbucket.org/wcauchois/pysvmlight
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = mercurial
+ depends = python2
+
+pkgname = python2-pysvmlight-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22b07218ce00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Stefan Seemayer <mail@semicolonsoftware.de>
+pkgname=python2-pysvmlight-hg
+pkgver=20130415
+pkgrel=1
+pkgdesc="A Python binding to the SVMlight support vector machine library by Thorsten Joachims"
+arch=("i686" "x86_64")
+url="https://bitbucket.org/wcauchois/pysvmlight"
+license=('unknown')
+makedepends=('mercurial')
+depends=('python2')
+
+_hgroot=ssh://hg@bitbucket.org/wcauchois/pysvmlight
+_hgrepo=pysvmlight
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to Mercurial server...."
+
+ if [[ -d "$_hgrepo" ]]; then
+ cd "$_hgrepo"
+ hg pull -u
+ msg "The local files are updated."
+ else
+ hg clone "$_hgroot" "$_hgrepo"
+ fi
+
+ msg "Mercurial checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_hgrepo-build"
+ cp -r "$srcdir/$_hgrepo" "$srcdir/$_hgrepo-build"
+ cd "$srcdir/$_hgrepo-build"
+
+}
+
+package() {
+ cd "$srcdir/$_hgrepo-build"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: