summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2020-10-01 03:02:56 +0300
committerLev Levitsky2020-10-01 03:02:56 +0300
commit1bdbde9504361aa1e084f63236c4468365d4c8d9 (patch)
tree2e88a337ad31f18c131dd98414352c7937431ef3
parent47d909e4872dcccb01c9a104ca82c0e8e0480cad (diff)
downloadaur-1bdbde9504361aa1e084f63236c4468365d4c8d9.tar.gz
4.3.3
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG19
-rw-r--r--PKGBUILD4
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8566268f2327..c09776d8ef72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.3.2
+ pkgver = 4.3.3
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -16,8 +16,8 @@ pkgbase = python2-pyteomics
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
optdepends = python2-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.3.2-py2.py3-none-any.whl
- sha256sums = 4947e1f7dbf8c6cdad9db9382e7eb5ef0288dbfbcfe5dfa2f629f3b8a5f394fb
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.3.3-py2.py3-none-any.whl
+ sha256sums = a4a0afb4f50fa236d87c552639bead600d13a2aae2cae883d1478c7ecf9fe90b
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 28f0657f7e13..7ff318be6672 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,22 @@
+4.3.3
+-----
+
+ - Add :py:func:`pyteomics.electrochem.gravy` (`#9 <https://github.com/levitsky/pyteomics/pull/9>`_).
+
+ - Fixes and improvements in :py:func:`pyteomics.pepxml.roc_curve` (`#10 <https://github.com/levitsky/pyteomics/pull/10>`_).
+
+ - Changes in guessing behavior of :py:func:`read` functions.
+
+ In modules that implement :ref:`indexing parsers <indexing>` for non-XML formats (MGF, FASTA, PEFF, ms1/ms2),
+ when a parser is instantiated using :py:func:`read`, the parser class to instantiate is guessed
+ based on the mode of the file object passed to :py:func:`read` (text or binary).
+
+ With some file-like objects, mode cannot be easily deduced without consuming some of the data.
+ You will now see more warnings in case `use_index` is not explicitly passed to :py:func:`read` and reading mode is not obvious.
+ There will also be warnings if `use_index` is specified but the file is opened in the wrong mode.
+ To avoid all of this, you are encouraged to instantiate parser classes directly,
+ or explicitly specify `use_index` to :py:func:`read` in all corner cases.
+
4.3.2
-----
diff --git a/PKGBUILD b/PKGBUILD
index 160d56d81118..39c94b9f1770 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.3.2
+pkgver=4.3.3
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('4947e1f7dbf8c6cdad9db9382e7eb5ef0288dbfbcfe5dfa2f629f3b8a5f394fb')
+sha256sums=('a4a0afb4f50fa236d87c552639bead600d13a2aae2cae883d1478c7ecf9fe90b')
changelog=CHANGELOG
package() {