summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2021-09-20 18:19:56 +0300
committerLev Levitsky2021-09-20 18:19:56 +0300
commit27b44891fec9ecd4185df4245a65d091bd9525fe (patch)
tree20e1b426b347b1f4bd6ccc68113f4977f2443b85
parent70058c3ae98d7b2fff459e17cd21dfbfd7348498 (diff)
downloadaur-27b44891fec9ecd4185df4245a65d091bd9525fe.tar.gz
Version 4.5
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG44
-rw-r--r--PKGBUILD4
3 files changed, 49 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b47c7dff477..a8989e831c9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.4.2
+ pkgver = 4.5
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -16,8 +16,7 @@ pkgbase = python2-pyteomics
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
optdepends = python2-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.4.2-py2.py3-none-any.whl
- sha256sums = 4dc72253a4727bda9bcb1b11a46c5ed13dd8a4c1fb0e35dda094420b1ef26044
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.5-py2.py3-none-any.whl
+ sha256sums = 48ea75a6228a659fc3fb57da174f7c2632a9d296f8fe271595734e062f5f218e
pkgname = python2-pyteomics
-
diff --git a/CHANGELOG b/CHANGELOG
index 072b9f3abf9e..3617323334f8 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,47 @@
+4.5
+---
+
+ - Add support for `mzMLb <https://www.biorxiv.org/content/10.1101/2020.02.13.947218v3>`_
+ (`#35 <https://github.com/levitsky/pyteomics/pull/35>`_
+ and `#38 <https://github.com/levitsky/pyteomics/pull/38>`_ by Joshua Klein)
+ with new module :py:mod:`pyteomics.mzmlb`.
+
+ - Add ProteomeExchange backend for PROXI requests and implement an aggregator for responses from all backends
+ (`#36 <https://github.com/levitsky/pyteomics/pull/36>`_,
+ `#45 <https://github.com/levitsky/pyteomics/pull/45>`_, and
+ `#55 <https://github.com/levitsky/pyteomics/pull/55>`_ by Joshua Klein)
+ in :py:mod:`pyteomics.usi`.
+
+ - Add support for `ProForma <https://www.psidev.info/proforma>`_
+ (`#37 <https://github.com/levitsky/pyteomics/pull/37>`_ by Joshua Klein)
+ in new module :py:mod:`pyteomics.proforma`.
+
+ - New arguments `keep_nterm_M` and `fix_aa` in :py:func:`pyteomics.fasta.shuffle`
+ (`#54 <https://github.com/levitsky/pyteomics/pull/54>`_ by Vladimir Gorshkov).
+
+ - Fx for unwanted warnings in :py:func:`pyteomics.auxiliary.file_helpers._check_use_index` when
+ `use_index` is explicitly passed (`#52 <https://github.com/levitsky/pyteomics/issues/52>`_).
+
+ - Update the default XML schema for featureXML and fix issues with incorrectly specified data types
+ (`#53 <https://github.com/levitsky/pyteomics/pull/53>`_).
+
+ - Add a new backend for spectrum annotation and plotting. :py:func:`pyteomics.pylab_aux.plot_spectrum` and
+ :py:func:`pyteomics.pylab_aux.annotate_spectrum` can now use
+ `spectrum_utils <https://github.com/bittremieux/spectrum_utils>`_ under the hood
+ (`#43 <https://github.com/levitsky/pyteomics/pull/43>`_).
+
+ See new `Example 4 <examples/example_annotation.html>`_ for demonstration.
+
+ - New function :py:func:`pyteomics.pylab_aux.mirror` for making a
+ `spectrum_utils <https://github.com/bittremieux/spectrum_utils>`_ mirror plot.
+
+ - :py:func:`pyteomics.pylab_aux.plot_spectrum` and :py:func:`pyteomics.pylab_aux.annotate_spectrum` now
+ always return :py:class:`matplotlib.pyplot.Axes`.
+
+ - Add a warning when passing an existing file by name in writing functions.
+ The default mode for output files will change from `'a'` to `'w'` in a future version.
+
+
4.4.2
-----
diff --git a/PKGBUILD b/PKGBUILD
index 6217b7cea0ab..6c21efd394b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.4.2
+pkgver=4.5
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('4dc72253a4727bda9bcb1b11a46c5ed13dd8a4c1fb0e35dda094420b1ef26044')
+sha256sums=('48ea75a6228a659fc3fb57da174f7c2632a9d296f8fe271595734e062f5f218e')
changelog=CHANGELOG
package() {