summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2015-09-22 23:01:56 +0300
committerLev Levitsky2015-09-22 23:03:43 +0300
commit6a270588fd8aea829c3575b415dea7067eb98ba6 (patch)
treeb9ba4dc9bb874619f56db6d0d3e08cba132fefdb
parent72a36dec00eb5fc9065856f35905baa4b1027776 (diff)
downloadaur-6a270588fd8aea829c3575b415dea7067eb98ba6.tar.gz
Version 3.1
-rw-r--r--.SRCINFO11
-rw-r--r--CHANGELOG43
-rw-r--r--PKGBUILD8
3 files changed, 52 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7af7e9639d9a..5d5dbf64c902 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
-# Generated by makepkg 4.2.1
-# Wed Apr 15 22:17:40 UTC 2015
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.0.1
- pkgrel = 1
+ pkgver = 3.1
+ pkgrel = 2
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
arch = any
license = Apache
depends = python2
+ depends = python2-setuptools
optdepends = python2-matplotlib: for pylab_aux module, optional
optdepends = python2-lxml: for XML parsing modules, recommended
optdepends = python2-numpy: for lots of features, highly recommended
options = !emptydirs
- source = https://pypi.python.org/packages/source/p/pyteomics/pyteomics-3.0.1.tar.gz
- md5sums = 2c838cc1c16dce69148662b883c755b9
+ source = https://pypi.python.org/packages/source/p/pyteomics/pyteomics-3.1.tar.gz
+ md5sums = 5e4c8d38f0891e82b8ec30515ce6718f
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index a9f2bb997e99..7dcb0ee07f39 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,45 @@
+3.1
+---
+
+This release offers integration with the great :py:mod:`pandas` library.
+Working with :py:func:`qvalues` and :py:func:`!filter` functions
+is now much easier if you have your PSMs in a :py:class:`DataFrame`.
+Many search engines use CSV as their output format, allowing direct
+creation of :py:class:`DataFrame` objects. New functions
+:py:func:`pyteomics.tandem.DataFrame` and :py:func:`pyteomics.pepxml.DataFrame`
+faciliatate creation of DataFrames from corresponding formats.
+
+Also, :py:func:`qvalues`, :py:func:`!filter` and :py:func:`fdr` functions can now use
+posterior error probabilities (PEPs) instead of using decoys for q-value calculation.
+
+ - In :py:func:`qvalues` and :py:func:`!filter` functions,
+ `key` and `is_decoy` can now be array-like objects or strings
+ (as well as functions and iterators).
+ If a string is given, it is used as a field name in the PSM array
+ or :py:class:`DataFrame`. :py:func:`fdr` functions also support strings
+ and iterables as arguments.
+
+ - New parameter `pep` in :py:func:`qvalues`, :py:func:`!filter` and :py:func:`fdr` functions.
+ It can be callable, array-like, or iterator. Conflicts with decoy-related
+ parameters. Compatible with `key`, but makes it optional.
+
+ - Fixed the behavior of :py:func:`filter.chain` functions. They now treat
+ the `full_output` argument the same way as :py:func:`!filter` functions.
+
+ - Fixed the issue that caused exceptions when calling :py:func:`fasta.decoy_db`
+ and :py:func:`fasta.write_decoy_db` with explicitly given `mode` (signature
+ for creation of :py:class:`pyteomics.auxiliary.FileReader` objects slightly changed).
+
+ - Pyteomics now uses `setuptools` and is a namespace package.
+
+ - Minor fixes.
+
+
+API changes
+...........
+
+- Default value of `remove_decoy` in :py:func:`qvalues` is now :py:const:`False`.
+
3.0.1
-----
@@ -8,6 +50,7 @@
3.0.0
-----
+
- XML parsers are now implemented as objects, each format has its own class.
Those classes can be instantiated using the same arguments as :py:func:`read`
functions accepted, and support direct iteration and the ``with`` syntax.
diff --git a/PKGBUILD b/PKGBUILD
index 811249bb4941..cac75f4d731e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=3.0.1
-pkgrel=1
+pkgver=3.1
+pkgrel=2
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="http://pythonhosted.org/pyteomics"
license=('Apache')
-depends=('python2')
+depends=('python2' 'python2-setuptools')
optdepends=('python2-matplotlib: for pylab_aux module, optional' \
'python2-lxml: for XML parsing modules, recommended' \
'python2-numpy: for lots of features, highly recommended')
options=(!emptydirs)
source=("https://pypi.python.org/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('2c838cc1c16dce69148662b883c755b9')
+md5sums=('5e4c8d38f0891e82b8ec30515ce6718f')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"