summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2020-02-03 23:14:23 +0300
committerLev Levitsky2020-02-03 23:14:23 +0300
commit6b30ca54ec9150408398d7fc5a0f3574fb022f47 (patch)
treee7200eb276706d4774b5e13071c7fbc33fad5f7d
parentefe4364a447713c7d26b7d0d97f9be847aae3b2a (diff)
downloadaur-6b30ca54ec9150408398d7fc5a0f3574fb022f47.tar.gz
4.2
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG47
-rw-r--r--PKGBUILD6
-rw-r--r--python2-pyteomics.install12
4 files changed, 49 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82f7b817a1bf..0d5d2a215eb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.1.2
+ pkgver = 4.2
pkgrel = 1
url = https://pyteomics.readthedocs.io
- install = python2-pyteomics.install
changelog = CHANGELOG
arch = any
license = Apache
@@ -16,8 +15,8 @@ pkgbase = python2-pyteomics
optdepends = python2-numpy: for most of features, highly recommended
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.2.tar.gz
- sha256sums = 8eef7f325bb818fe403e3c0859b36eecd22efbd4012d7610f51479d88ced72a2
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.2.tar.gz
+ sha256sums = e4762659520b518df0d75e9fc2a1a011315fd0835ec501ae81583275d340ef1d
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 72f042ff3daf..0322f6168600 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,46 @@
+4.2
+---
+
+ - Changes in XML XPath implementation.
+ For standard XML parser classes, this only means a minor change in performance
+ (should be a slight improvement, most noticeable for :py:class:`TandemXML`).
+
+ - For custom classes: the implementation of xpath evaluation in :py:meth:`pyteomics.xml.XML.iterfind` has changed.
+ Pseudo-conditions are now not supported. Instead, an attempt is made to support full XPath.
+ The main difference is that the XPath is evaluated on XML elements,
+ whereas pseudo-conditions used to be evaluated for complete Python dictionaries.
+ To reproduce old behavior, you can just write an explicit `if` statement at an appropriate place.
+ New implementation allows actually skipping the elements that do not satisfy the XPath predicate.
+ When writing classes which by default iterate over elements based on a complex XPath, set
+ :py:attr:`_default_iter_path` instead of :py:attr:`_default_iter_tag`.
+
+ .. warning ::
+ Beware that if :py:attr:`_default_iter_path` differs from :py:attr:`_default_iter_tag` and you use indexing,
+ all elements corresponding to :py:attr:`_default_iter_tag` will be indexed.
+ This is a limitation of the index building procedure.
+ This discrepancy will lead to confusing behavior
+ (length checks, membership tests and other things based on index
+ will not correspond to items returned by iteration).
+ :py:meth:`map` calls will also operate on the full index.
+
+
+ - New keyword arguments `queue_size`, `queue_timeout` and `processes` for indexed parsers with support for :py:meth:`map`.
+
+ - New method :py:meth:`mass.Unimod.by_id`.
+ Also, :py:class:`mass.Unimod` now supports dict-like queries with record IDs.
+
+ - Reduce memory footprint for unit primitives (PR #35 by Joshua Klein).
+
+ - New functions :py:func:`pyteomics.auxiliary.sigma_T` and :py:func:`pyteomics.auxiliary.sigma_fdr`.
+
+ - Fix issues #44, #46, #47, #48.
+
+
+4.1.2
+-----
+
+Bugfix: fix the standard mass value for pyrrolysine (issue #42).
+
4.1.1
-----
@@ -5,10 +48,6 @@
To read files compressed with Numpress, install `pynumpress`
(`PyPI <https://pypi.org/project/pynumpress/>`_, `GitHub <https://github.com/mobiusklein/pynumpress>`_).
- .. note:: There is a `known issue
- <https://bitbucket.org/levitsky/pyteomics/issues/37/add-numpress-support-in-mzml#comment-51540079>`_
- with `pynumpress` on Linux and Python 2.7, which is contingent on a fix in Cython.
-
- Bugfixes.
API changes
diff --git a/PKGBUILD b/PKGBUILD
index cbbfda8bfb2d..035fc76bd174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.1.2
+pkgver=4.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -15,8 +15,8 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-dill: needed for multiprocessing when pickle is not enough')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-install="${pkgname}.install"
-sha256sums=('8eef7f325bb818fe403e3c0859b36eecd22efbd4012d7610f51479d88ced72a2')
+install=
+sha256sums=('e4762659520b518df0d75e9fc2a1a011315fd0835ec501ae81583275d340ef1d')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"
diff --git a/python2-pyteomics.install b/python2-pyteomics.install
deleted file mode 100644
index ab64d3be6a30..000000000000
--- a/python2-pyteomics.install
+++ /dev/null
@@ -1,12 +0,0 @@
-## arg 1: the new package version
-post_install() {
- echo 'If you need Numpress support, install cython2 and do: pip2 install git+https://github.com/mobiusklein/pynumpress'
-}
-
-## arg 1: the new package version
-## arg 2: the old package version
-post_upgrade() {
- echo 'If you need Numpress support, install cython2 and do: pip2 install git+https://github.com/mobiusklein/pynumpress'
-}
-
-