summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlevitsky2017-07-02 15:13:35 +0300
committerlevitsky2017-07-02 15:13:35 +0300
commit9a1b592a4512d0ac64e03bbc75cfb29711baa4b2 (patch)
treeed5278453d3566d383cdb2ea3d30fec0c98ab517
parentc7f661fa785727dc1e93fbd497a6a7ef680ce5ea (diff)
downloadaur-9a1b592a4512d0ac64e03bbc75cfb29711baa4b2.tar.gz
python2 fix
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7e7e8f1c239..ed315e321784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = python-pyteomics
+pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
pkgver = 3.4.2
pkgrel = 1
@@ -6,16 +6,16 @@ pkgbase = python-pyteomics
changelog = CHANGELOG
arch = any
license = Apache
- depends = python
- depends = python-setuptools
- optdepends = python-matplotlib: for pylab_aux module
- optdepends = python-sqlalchemy: for mass.unimod module
- optdepends = python-pandas: for convenient filtering of CSV tables from search engines
- optdepends = python-lxml: for XML parsing modules
- optdepends = python-numpy: for most of features, highly recommended
+ depends = python2
+ depends = python2-setuptools
+ optdepends = python2-matplotlib: for pylab_aux module
+ optdepends = python2-sqlalchemy: for mass.unimod module
+ optdepends = python2-pandas: for convenient filtering of CSV tables from search engines
+ optdepends = python2-lxml: for XML parsing modules
+ optdepends = python2-numpy: for most of features, highly recommended
options = !emptydirs
source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.2.tar.gz
md5sums = 36cc4c3bab653fdbe22aec71858a461f
-pkgname = python-pyteomics
+pkgname = python2-pyteomics
diff --git a/PKGBUILD b/PKGBUILD
index 5b10fe3c5068..8002e148a0ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
-pkgname=python-pyteomics
+pkgname=python2-pyteomics
pkgver=3.4.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="http://pyteomics.readthedocs.io/"
license=('Apache')
-depends=('python' 'python-setuptools')
-optdepends=('python-matplotlib: for pylab_aux module'
- 'python-sqlalchemy: for mass.unimod module'
- 'python-pandas: for convenient filtering of CSV tables from search engines'
- 'python-lxml: for XML parsing modules'
- 'python-numpy: for most of features, highly recommended')
+depends=('python2' 'python2-setuptools')
+optdepends=('python2-matplotlib: for pylab_aux module'
+ 'python2-sqlalchemy: for mass.unimod module'
+ 'python2-pandas: for convenient filtering of CSV tables from search engines'
+ 'python2-lxml: for XML parsing modules'
+ 'python2-numpy: for most of features, highly recommended')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
md5sums=('36cc4c3bab653fdbe22aec71858a461f')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}
# vim:set ts=2 sw=2 et: