summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2020-05-18 23:45:59 +0300
committerLev Levitsky2020-05-18 23:45:59 +0300
commitc81c86ac759f41e124ced1a774107ba4a9d2455e (patch)
treee1487217fdb2ae9639e3ef06014e45b33334bc22
parent6b30ca54ec9150408398d7fc5a0f3574fb022f47 (diff)
downloadaur-c81c86ac759f41e124ced1a774107ba4a9d2455e.tar.gz
4.3.1
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG21
-rw-r--r--PKGBUILD16
3 files changed, 33 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5d2a215eb1..ed4a58e4310a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.2
+ pkgver = 4.3.1
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
arch = any
license = Apache
depends = python2
- depends = python2-setuptools
+ depends = python2-pip
optdepends = python2-matplotlib: for pylab_aux module
optdepends = python2-sqlalchemy: for mass.unimod module
optdepends = python2-pandas: for convenient filtering of CSV tables from search engines
optdepends = python2-lxml: for XML parsing modules
optdepends = python2-numpy: for most of features, highly recommended
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
+ optdepends = python2-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.2.tar.gz
- sha256sums = e4762659520b518df0d75e9fc2a1a011315fd0835ec501ae81583275d340ef1d
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.3.1-py2.py3-none-any.whl
+ sha256sums = be9367c5b9a828c11c7df943d5bed8ee24b5d2d5b63676fcddd789ea5ad98b73
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 0322f6168600..7edfec758cd5 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,22 @@
+4.3.1
+-----
+
+Technical release.
+
+4.3
+---
+
+First release after the move to Github. Issue and PR numbers from now on refer to the
+`Github repo <https://github.com/levitsky/pyteomics>`_. Archive of the Bibucket issues and PRs is stored
+`here <https://levitsky.github.io/bitbucket_backup/#!/levitsky/pyteomics>`_.
+
+Changes in this release:
+
+ - New module :py:mod:`pyteomics.openms.idxml`.
+
+ - Fix `#3 <https://github.com/levitsky/pyteomics/issues/3>`_, `#5 <https://github.com/levitsky/pyteomics/issues/5>`_,
+ and some issues in :py:mod:`tandem`.
+
4.2
---
@@ -76,7 +95,7 @@ API changes
4.0.1
-----
-Fix issue `#35 <https://bitbucket.org/levitsky/pyteomics/issues/35/ordereddict-may-be-in-reversed-order-on>`_
+Fix issue `#35 <hhttps://levitsky.github.io/bitbucket_backup/#!/levitsky/pyteomics/issues/35/page/1>`_
(incorrect order of deserialized offset indexes on older Python versions).
4.0
diff --git a/PKGBUILD b/PKGBUILD
index 035fc76bd174..2120f7652b55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.2
+pkgver=4.3.1
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="https://pyteomics.readthedocs.io"
license=('Apache')
-depends=('python2' 'python2-setuptools')
+depends=('python2' 'python2-pip')
optdepends=('python2-matplotlib: for pylab_aux module'
'python2-sqlalchemy: for mass.unimod module'
'python2-pandas: for convenient filtering of CSV tables from search engines'
'python2-lxml: for XML parsing modules'
'python2-numpy: for most of features, highly recommended'
- 'python2-dill: needed for multiprocessing when pickle is not enough')
+ 'python2-dill: needed for multiprocessing when pickle is not enough'
+ 'python2-pynumpress: for Numpress support')
options=(!emptydirs)
-source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-install=
-sha256sums=('e4762659520b518df0d75e9fc2a1a011315fd0835ec501ae81583275d340ef1d')
+source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
+sha256sums=('be9367c5b9a828c11c7df943d5bed8ee24b5d2d5b63676fcddd789ea5ad98b73')
changelog="CHANGELOG"
+
package() {
- cd "${srcdir}/pyteomics-${pkgver}"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ pip2 install --ignore-installed --root "$pkgdir" "pyteomics-${pkgver}-py2.py3-none-any.whl"
}
# vim:set ts=2 sw=2 et: