summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2019-05-07 15:37:29 +0300
committerLev Levitsky2019-05-07 15:37:29 +0300
commitd1eb3fbde5613481bdb9694fbe9e5c58da2eea2f (patch)
tree391847acdb0d78c17dd2cfebf6061a4ec81ba178
parent72f72ca6041c82bfa2d6d5757f9e982170e82c14 (diff)
downloadaur-d1eb3fbde5613481bdb9694fbe9e5c58da2eea2f.tar.gz
Release 4.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG19
-rw-r--r--PKGBUILD4
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf0e289c54d..88fdc798922d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.1
+ pkgver = 4.1.1
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -15,8 +15,8 @@ pkgbase = python2-pyteomics
optdepends = python2-numpy: for most of features, highly recommended
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.tar.gz
- sha256sums = d7eaa5a1c6f25a39a42c4846e8c39e23cd3ba6f1aeeeedb730c3911c82bf6633
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.1.tar.gz
+ sha256sums = 384e4e5eabdbfec39d7c38369278e386a074c7066f33052d7c313af40f1aa45e
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 7f415978efda..72f042ff3daf 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,22 @@
+4.1.1
+-----
+
+ - Add `numpress <https://dx.doi.org/10.1074%2Fmcp.O114.037879>`_ support for mzML and mzXML files.
+ To read files compressed with Numpress, install `pynumpress`
+ (`PyPI <https://pypi.org/project/pynumpress/>`_, `GitHub <https://github.com/mobiusklein/pynumpress>`_).
+
+ .. note:: There is a `known issue
+ <https://bitbucket.org/levitsky/pyteomics/issues/37/add-numpress-support-in-mzml#comment-51540079>`_
+ with `pynumpress` on Linux and Python 2.7, which is contingent on a fix in Cython.
+
+ - Bugfixes.
+
+API changes
+...........
+
+ - In :py:func:`ms1.read` and :py:func:`ms2.read`, the default value for `use_index` is now :py:const:`False`.
+ Using the indexed parsers may result in incorrect behavior if the "first" scan number in S-lines is not unique.
+
4.1
---
diff --git a/PKGBUILD b/PKGBUILD
index c87b4d77d079..991d6af21e41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.1
+pkgver=4.1.1
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -15,7 +15,7 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-dill: needed for multiprocessing when pickle is not enough')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-sha256sums=('d7eaa5a1c6f25a39a42c4846e8c39e23cd3ba6f1aeeeedb730c3911c82bf6633')
+sha256sums=('384e4e5eabdbfec39d7c38369278e386a074c7066f33052d7c313af40f1aa45e')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"