summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2016-09-08 23:09:22 +0300
committerLev Levitsky2016-09-08 23:09:22 +0300
commite00552b80e75fc06cf54c2cadbcec058d2fe7bcf (patch)
treeb2d94e5a06cc21978b980737135475225248ff6e
parentbe69b00dd429dfbfd267a34f96ff14bd604445df (diff)
downloadaur-e00552b80e75fc06cf54c2cadbcec058d2fe7bcf.tar.gz
Version 3.4
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG25
-rw-r--r--PKGBUILD4
3 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b309dcb2b35..d0cca085c0b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 2 12:51:18 UTC 2016
+# Thu Sep 8 20:08:35 UTC 2016
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.3.1
+ pkgver = 3.4
pkgrel = 1
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
@@ -16,8 +16,8 @@ pkgbase = python2-pyteomics
optdepends = python2-lxml: for XML parsing modules
optdepends = python2-numpy: for most of features, highly recommended
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.3.1.tar.gz
- md5sums = 0b81c096944334c53ee52c213a42edee
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.tar.gz
+ md5sums = 3c8d1bcc16c53100e531a10a2853f679
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index f6c6d142edfc..15672ad90dd2 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,22 @@
+3.4
+---
+
+ - New module :py:mod:`pyteomics.mzxml` for parsing of MzXML files.
+
+ - New parameter `dtype` in :py:func:`pyteomics.mgf.read`, :py:func:`pyteomics.mzml.read`
+ and :py:func:`pyteomics.mzxml.read`
+ allows changing the dtype of arrays yielded by the parsers.
+
+ - :py:mod:`pyteomics.featurexml` moved into a subpackage :py:mod:`pyteomics.openms`.
+
+ - New module :py:mod:`pyteomics.openms.trafoxml` for OpenMS transformation files.
+
+ - Bugfix in XML indexing code to make it work on Python 3.x versions prior to 3.5.
+
+ - Bugfix in :py:func:`pyteomics.pylab_aux.scatter_trend` (support for lists and other non-ndarrays).
+
+ - Performance improvements in :py:mod:`pyteomics.achrom` calibration functions.
+
3.3.1
-----
@@ -5,10 +24,10 @@ New submodule :py:mod:`pyteomics.featurexml` with a parser for OpenMS **featureX
3.3
---
-
+
- mzML and mzIdentML parsers can now create an index of element offsets.
This allows quick random access to elements by unique ID.
-
+
- mzML parsers now come in two flavors: :py:class:`pyteomics.mzml.MzML` and
:py:class:`pyteomics.mzml.PreIndexedMzML`. The latter uses the byte offsets
listed at the end of the file.
@@ -81,7 +100,7 @@ Other changes:
- Bugfix in :py:mod:`pyteomics.auxiliary`.
- New parameter `show_legend` in :py:func:`pyteomics.pylab_aux.scatter_trend`.
-
+
- Performance improvements in :py:mod:`pyteomics.parser`.
3.1
diff --git a/PKGBUILD b/PKGBUILD
index f72866b91fea..73f3f535cf59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=3.3.1
+pkgver=3.4
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -14,7 +14,7 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-numpy: for most of features, highly recommended')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('0b81c096944334c53ee52c213a42edee')
+md5sums=('3c8d1bcc16c53100e531a10a2853f679')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"