summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2021-01-30 20:21:46 +0300
committerLev Levitsky2021-01-30 20:21:46 +0300
commiteb604c90dab4437c1dfff68f9faee28865f977bb (patch)
tree948ddd8c9bf74e4f520a5a0aa8a173593572a8c6
parente5eeca9ae82ec7a58a961815aa3942b0213e0791 (diff)
downloadaur-eb604c90dab4437c1dfff68f9faee28865f977bb.tar.gz
4.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG14
-rw-r--r--PKGBUILD4
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73b9b50c99ea..19da15ef7cd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.4.0
+ pkgver = 4.4.1
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -16,8 +16,8 @@ pkgbase = python2-pyteomics
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
optdepends = python2-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.4.0-py2.py3-none-any.whl
- sha256sums = d170c57ccdbe148668ff3c8e8324637b6f7bc67964d6b73b9228134d6a2c1cd1
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.4.1-py2.py3-none-any.whl
+ sha256sums = ab7ac3a762507d3849dcf19308e8d67d7ba9ccf3f3961d58c9cc9892850c5374
pkgname = python2-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 8b5cb8dcf7d0..ffb4d005933c 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,17 @@
+4.4.1
+-----
+
+ - Further tweaked behavior of :py:func:`pyteomics.auxiliary.file_helpers._check_use_index`, which is responsible for
+ handling of `use_index` in :py:func:`read` functions in parser modules.
+
+ - Fix indexing when element identifiers contain XML-escaped characters
+ (`#20 <https://github.com/levitsky/pyteomics/pull/20>`_ by Joshua Klein).
+
+ - Add support for MzTab 2.0 (`#22 <https://github.com/levitsky/pyteomics/pull/22>`_ by @annalefarova).
+
+ - Also, check out the `Pyteomics Discussions page <https://github.com/levitsky/pyteomics/discussions>`_!
+ You can use it to share your thoughts, ask questions, discuss coding practices, etc.
+
4.4
---
diff --git a/PKGBUILD b/PKGBUILD
index 18ffc6ab4fd7..4118a6d63a12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.4.0
+pkgver=4.4.1
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('d170c57ccdbe148668ff3c8e8324637b6f7bc67964d6b73b9228134d6a2c1cd1')
+sha256sums=('ab7ac3a762507d3849dcf19308e8d67d7ba9ccf3f3961d58c9cc9892850c5374')
changelog=CHANGELOG
package() {