summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2019-06-07 19:15:32 +0300
committerLev Levitsky2019-06-07 19:15:32 +0300
commitefe4364a447713c7d26b7d0d97f9be847aae3b2a (patch)
tree2ff5cf423c385e16307900c1432cb943abaaef73
parentd1eb3fbde5613481bdb9694fbe9e5c58da2eea2f (diff)
downloadaur-efe4364a447713c7d26b7d0d97f9be847aae3b2a.tar.gz
Release 4.1.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
-rw-r--r--python2-pyteomics.install12
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88fdc798922d..82f7b817a1bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = python2-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.1.1
+ pkgver = 4.1.2
pkgrel = 1
url = https://pyteomics.readthedocs.io
+ install = python2-pyteomics.install
changelog = CHANGELOG
arch = any
license = Apache
@@ -15,8 +16,8 @@ pkgbase = python2-pyteomics
optdepends = python2-numpy: for most of features, highly recommended
optdepends = python2-dill: needed for multiprocessing when pickle is not enough
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.1.tar.gz
- sha256sums = 384e4e5eabdbfec39d7c38369278e386a074c7066f33052d7c313af40f1aa45e
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.2.tar.gz
+ sha256sums = 8eef7f325bb818fe403e3c0859b36eecd22efbd4012d7610f51479d88ced72a2
pkgname = python2-pyteomics
diff --git a/PKGBUILD b/PKGBUILD
index 991d6af21e41..cbbfda8bfb2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python2-pyteomics
-pkgver=4.1.1
+pkgver=4.1.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -15,7 +15,8 @@ optdepends=('python2-matplotlib: for pylab_aux module'
'python2-dill: needed for multiprocessing when pickle is not enough')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-sha256sums=('384e4e5eabdbfec39d7c38369278e386a074c7066f33052d7c313af40f1aa45e')
+install="${pkgname}.install"
+sha256sums=('8eef7f325bb818fe403e3c0859b36eecd22efbd4012d7610f51479d88ced72a2')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"
diff --git a/python2-pyteomics.install b/python2-pyteomics.install
new file mode 100644
index 000000000000..ab64d3be6a30
--- /dev/null
+++ b/python2-pyteomics.install
@@ -0,0 +1,12 @@
+## arg 1: the new package version
+post_install() {
+ echo 'If you need Numpress support, install cython2 and do: pip2 install git+https://github.com/mobiusklein/pynumpress'
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ echo 'If you need Numpress support, install cython2 and do: pip2 install git+https://github.com/mobiusklein/pynumpress'
+}
+
+