summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:10:00 +0100
committermschubert2015-06-12 12:10:00 +0100
commitc054ea8ae25f3d2e266daef168bcb76c947284c2 (patch)
treea4cfec43f16400c2551ff8771f210be2afa91fb1
downloadaur-c054ea8ae25f3d2e266daef168bcb76c947284c2.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
3 files changed, 73 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e3b92cb3f35d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-pythonmagick
+ pkgdesc = Object-oriented Python2 bindings for the ImageMagick library
+ pkgver = 0.9.11
+ pkgrel = 2
+ url = http://www.imagemagick.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = perl
+ makedepends = automake
+ depends = boost
+ depends = python2
+ depends = imagemagick
+ options = !libtool
+ source = http://www.imagemagick.org/download/python/PythonMagick-0.9.11.tar.gz
+ md5sums = 8af559d540a8e976d830ede9c79c683e
+
+pkgname = python2-pythonmagick
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3b92cb3f35d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-pythonmagick
+ pkgdesc = Object-oriented Python2 bindings for the ImageMagick library
+ pkgver = 0.9.11
+ pkgrel = 2
+ url = http://www.imagemagick.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = perl
+ makedepends = automake
+ depends = boost
+ depends = python2
+ depends = imagemagick
+ options = !libtool
+ source = http://www.imagemagick.org/download/python/PythonMagick-0.9.11.tar.gz
+ md5sums = 8af559d540a8e976d830ede9c79c683e
+
+pkgname = python2-pythonmagick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e84f5b03824
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=python2-pythonmagick
+pkgver=0.9.11
+pkgrel=2
+pkgdesc="Object-oriented Python2 bindings for the ImageMagick library"
+arch=('i686' 'x86_64')
+url="http://www.imagemagick.org/"
+license=('custom')
+depends=('boost' 'python2' 'imagemagick') # 'libstdc++5')
+makedepends=('perl' 'automake')
+options=('!libtool')
+source=("http://www.imagemagick.org/download/python/PythonMagick-$pkgver.tar.gz")
+md5sums=('8af559d540a8e976d830ede9c79c683e')
+
+build() {
+ cd "$srcdir/PythonMagick-$pkgver"
+ ./autogen.pl
+
+ CPPFLAGS="`python2-config --includes`" \
+ PYTHON_LIB="`python2-config --libs`" \
+ ./configure --prefix=/usr
+
+# sed -i 's:-l$(PYTHON_LIB):$(PYTHON_LIB):' Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/PythonMagick-$pkgver"
+ pydir=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
+
+ make DESTDIR="$pkgdir" pyexecdir="$pydir" pythondir="$pydir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/python2-pythonmagick/LICENSE"
+}
+