summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMcNoggins2015-06-11 21:55:56 -0400
committerMcNoggins2015-06-11 21:55:56 -0400
commitaba7081f3edf9900699f0b53a230ae166fe17884 (patch)
tree0bca3c4e51c564ebd22c28fe3b7f215b03abfb86
downloadaur-aba7081f3edf9900699f0b53a230ae166fe17884.tar.gz
Initial aur4 import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rw-r--r--bash_completion.patch12
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d886cfab427
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-pythonpy
+ pkgdesc = command line kung fu with python (python -c, with tab completion and shorthand)
+ pkgver = 0.3.7
+ pkgrel = 2
+ url = https://github.com/Russell91/pythonpy
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ optdepends = bash-completion: shell completion support
+ provides = python2-pythonpy
+ conflicts = python-pythonpy
+ source = https://pypi.python.org/packages/source/p/pythonpy/pythonpy-0.3.7.tar.gz
+ source = bash_completion.patch
+ sha256sums = 6822f9c925f4e3e837698ec9569f343221fdaa32c61374e259cc90fd7d40029e
+ sha256sums = c3dfc5951d9e97dbfd5a64f63f29a7f851c24c6bba565a9594bc7614303f9f69
+
+pkgname = python2-pythonpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10b41ff438ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: McNoggins <gagnon88 (at) Gmail (dot) com>
+pkgname="python2-pythonpy"
+pkgver=0.3.7
+pkgrel=2
+pkgdesc="command line kung fu with python (python -c, with tab completion and shorthand)"
+arch=('any')
+url="https://github.com/Russell91/pythonpy"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+optdepends=('bash-completion: shell completion support')
+provides=('python2-pythonpy')
+conflicts=('python-pythonpy')
+source=("https://pypi.python.org/packages/source/p/pythonpy/pythonpy-$pkgver.tar.gz"
+ "bash_completion.patch")
+sha256sums=('6822f9c925f4e3e837698ec9569f343221fdaa32c61374e259cc90fd7d40029e'
+ 'c3dfc5951d9e97dbfd5a64f63f29a7f851c24c6bba565a9594bc7614303f9f69')
+
+prepare() {
+ cd "$srcdir/pythonpy-$pkgver"
+ patch -Np1 -i ../bash_completion.patch
+}
+
+package() {
+ cd "$srcdir/pythonpy-$pkgver"
+
+ # Setup package
+ python2 setup.py install --root="$pkgdir"
+}
diff --git a/bash_completion.patch b/bash_completion.patch
new file mode 100644
index 000000000000..466e6ecc54ee
--- /dev/null
+++ b/bash_completion.patch
@@ -0,0 +1,12 @@
+diff -aur pythonpy-0.3.7.pristine/setup.py pythonpy-0.3.7.new/setup.py
+--- pythonpy-0.3.7.pristine/setup.py 2015-02-09 19:54:50.089070067 -0500
++++ pythonpy-0.3.7.new/setup.py 2015-02-09 19:55:04.119070198 -0500
+@@ -35,7 +35,7 @@
+ ******************************************************************************''')
+ target='bash_completion.d'
+
+-data_files = [(target, ['pythonpy/pycompletion.sh']),]
++data_files = [('/etc/bash_completion.d', ['pythonpy/pycompletion.sh']),]
+
+ py_entry = 'py%s = pythonpy.__main__:main'
+ pycompleter_entry = 'pycompleter%s = pythonpy.pycompleter:main'