summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2016-07-30 21:46:14 +0200
committerAndrzej Giniewicz2016-07-30 21:46:14 +0200
commited25afefb23b4e401cbb74d8739c0ebf415b2954 (patch)
tree728f3c7f67d4c5d924c5ed6bf816dc078223bdca
downloadaur-ed25afefb23b4e401cbb74d8739c0ebf415b2954.tar.gz
python2-pythonqwt: first release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3500c903b48e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jul 30 19:45:36 UTC 2016
+pkgbase = python2-pythonqwt
+ pkgdesc = Qt plotting widgets for Python (pure Python reimplementation of Qwt C++ library)
+ pkgver = 0.5.5
+ pkgrel = 1
+ url = http://pythonhosted.org/PythonQwt/
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2-numpy
+ optdepends = python2-pyqt4: for Qt4 support
+ optdepends = python2-pyqt5: for Qt5 support
+ optdepends = spyder: for test launcher
+ options = !emptydirs
+ source = https://github.com/PierreRaybaut/PythonQwt/archive/v0.5.5.tar.gz
+ md5sums = bc030741a7acc9c0921554ac06ba593a
+
+pkgname = python2-pythonqwt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e22a4ab3629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=python2-pythonqwt
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="Qt plotting widgets for Python (pure Python reimplementation of Qwt C++ library)"
+arch=('any')
+url="http://pythonhosted.org/PythonQwt/"
+license=('custom') # mixed LGPL and MIT
+depends=('python2-numpy')
+optdepends=(
+ 'python2-pyqt4: for Qt4 support'
+ 'python2-pyqt5: for Qt5 support'
+ 'spyder: for test launcher'
+)
+makedepends=('python2-setuptools')
+options=(!emptydirs)
+
+source=("https://github.com/PierreRaybaut/PythonQwt/archive/v${pkgver}.tar.gz")
+md5sums=('bc030741a7acc9c0921554ac06ba593a')
+
+build() {
+ cd "$srcdir/PythonQwt-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/PythonQwt-$pkgver"
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+