summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:27:45 +0900
committerDaichi Shinozaki2015-06-09 18:27:45 +0900
commita45e4f93b22b2e26b9fd77c80f30af4f11387ffe (patch)
tree657c3e4f2abfc2429400d28dcc0cd2279f52098b
downloadaur-a45e4f93b22b2e26b9fd77c80f30af4f11387ffe.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..189fd5b07e2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pytrie
+ pkgdesc = A pure Python implementation of the trie data structure.
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://bitbucket.org/gsakkis/pytrie/
+ arch = any
+ license = UNKNOWN
+ makedepends = python2
+ depends = python2
+ source = https://pypi.python.org/packages/source/P/PyTrie/PyTrie-0.2.tar.gz
+ md5sums = 5997b46c854a68bc588f4527c987663a
+
+pkgname = python2-pytrie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..698a74456898
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Automatically generated by pip2arch on 2015-06-01
+
+pkgname=python2-pytrie
+pkgver=0.2
+pkgrel=1
+pkgdesc="A pure Python implementation of the trie data structure."
+url="http://bitbucket.org/gsakkis/pytrie/"
+depends=('python2' )
+makedepends=('python2' )
+license=('UNKNOWN')
+arch=('any')
+source=('https://pypi.python.org/packages/source/P/PyTrie/PyTrie-0.2.tar.gz')
+md5sums=('5997b46c854a68bc588f4527c987663a')
+
+build() {
+ cd $srcdir/PyTrie-0.2
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/PyTrie-0.2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}